Sandisk micro cruzer won't accept files but says it's empty!??

By macx
Oct 6, 2005
  1. Had used this to transfer info from an XP Pro machine to a 98/SE machine.
    Worked fine for several weeks.

    I wasn't aware of the USB Removal tool on the XP machine, so was
    unplugging it hot.

    Now it's quit accepting files (says the file cannot be created on the drive).
    Properties shows it to be full, but the drive file window doesn't show any files.

    Have tried to reformat, but maybe I'm not doing something right?

    Appreciate any suggestions!
  2. Tribal-Phoenix

    Tribal-Phoenix TS Rookie Posts: 92

    Is it in read only mode ?
  3. macx

    macx TS Evangelist Topic Starter Posts: 718

    Nope - checked that

    Like the title says -
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Reformat it as FAT32 on the 98 machine. For some reason doing it in XP doesn't fix those drives, but in 98 most of the time it does.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...