Server 2008: programs dont open/stutter/crash, at my wit's end

By digitill ยท 21 replies
Oct 28, 2008
  1. Hi everyone!

    So here goes another post from someone who mysteriously just showed up at your forums with this being his first contribution;) Anyhow, I am absolutely clueless about what to do besides wiping the system, its that annoying. The sheer multitude of problems made it impossible for me to find any useful info on the web:/ If anyone has an idea id be very thankful. Oh btw, Im a computer science major so talk nerdy to me, I think I can take it;)

    Here goes:
    Since about 2 days ago, my system (Windows Server 2008 Enterprise) comes up with all sorts of funny crashes and stutters in some games, unresponsivenes in other programs and at times downright ignores when I want to start a program. In detail:

    - Firefox: Temporarily unresponsive (greyed out)
    - Warcraft 3: Crashes from menu and game, seemingly at random. Cannot kill the process afterwards with task manager or process explorer, gotta reboot.
    - Bioshock: Stutters and hangs as early as in the first Logo screens and videos. Stutters last for about 5-10 secs, then game commences as normal for about the same amount of time, then more stutters. I checked procexp with the game windowed and it shows that the Bioshock.exe goes from ~60% cpu usage when acting normal to 3% and lower during the stutters. No other process is using the cpu time though, it just goes up and down every few seconds, letting the idle process have its share without anything else happening. At least killing the exe works as intended.
    - Other programs seem to run fine, e.g. Civ4 Colonization, MPlayer Classic, Messenger programs...

    I cannot remember (de-) installing anything vital prior to the issues, no hardware changes either ofc.
    These are my prime suspects atm:
    - My (Outpost) firewall (pro) is kinda new, so maybe I set up some rule thats not liked, but disabling the protection doesnt change anything.
    - My 2 WD6400AAKS hdds are 6months old and ran fine in a RAID0 for the first 4. BIOS then showed problems with one of them, system ran fine for a while still. A month ago the second drive was also "red" and my old vista started crashing and rebooting. I released the RAID and have them now running individually, WD Diagnostics shows no SMART errors and says everthing is fine :confused:
    - In the end, it can always be ram i guess. Next thing I will do is remove one piece at a time to see if one of the 2 sticks is faulty. Theyre not OCed btw.

    My System (see also my profile):
    E2160 @3GHZ (Sufficiently cooled, never had a problem so far)
    MSI Neo2-FR mobo
    2x 2GB G.SKILL ram
    2x WD6400AAKS hdd (no RAID atm)

    hijackthis log will follow in next post. Thanks a lot in advance u guys!
  2. digitill

    digitill TS Rookie Topic Starter

    Oh well, no links for newbs, I guess thats a sensible rule;)

    Attached the log.

    Thanks again for any suggestions!
  3. digitill

    digitill TS Rookie Topic Starter

    OK, ram is fine, just verified that.

    And I guess I forgot to mention its an x64 system.

    Edit: Just tried to copy 1Gb files into a folder on the same partition, Windows told me it would take about 3 hours. On another partition, it took a more normal 20 seconds. Smells like RMA for my hdd I guess, though I really have no idea why this should pop up during a RAID0, then disappear, then pop up again...

    Still very thankful for any ideas (maybe about how software could cause this).
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Too old, please uninstall HJT

    You could follow this process to confirm that you are clean

    Viruses/Spyware/Malware Preliminary Removal Instructions

    Also I read all posts, and edits, so your safe there. There's always someone reading anyway. :)
  5. digitill

    digitill TS Rookie Topic Starter

    Will do, thanks for reading.
  6. digitill

    digitill TS Rookie Topic Starter

    Well, here are the logs:

    1) Malwarebytes all drives but D:
    2) Malwarebytes D:
    3) SuperAntiSpyware all drives but D:
    4) SuperAntiSpyware D:
    5) HJT

    When trying Malwarebytes on D:, I aborted the process after it took 3:15:12 hh:mm:ss to scan 28440 objects and repeatedly being unresponsive to Windows. As u can see when comparing the SuperAntiSpyware log, it seems to have similar problems reading the files:/
    Seems that partition is having some trouble, would explain the problems in the games, these are stored on D:. Wouldnt explain the Problems with firefox and general unresponsiveness in some programs, all of which are on C:.

    Any ideas so far?
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I'm presently looking at your logs

    But this entry quickly alerted me:

    Running this program (as you presently are) is insecure (and probably not ideal for Server OS anyway !
    I would highly suggest that you un-install this file sharing program
    Otherwise Virus\Malware removal (if any) will be impaired by allowing more Virus\Malware to be downloaded to your computer.

    Please note, just turning off will not suffice, it must be removed to safe gaurd your Server OS
  8. digitill

    digitill TS Rookie Topic Starter

    Thanks again for ur quick reply.

    I will Remove utorrent if it makes you happy, but there is no installer for this, no registry entries, just the exe with its config files being executed when needed. I guess u would call it a portable program, at least the version I have. So there is no uninstalling of this, but I will for the sake of "thoroughness" (not a native speaker, please excuse;) ) delete its folder and current torrents.
  9. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    You have Daemon Tools installed
    Many users have this program, but it is found to be the source of many computer issues that I have seen
    I therefore suggest you un-install this too

    You have AVG installed
    AVG has been known to slow down computers dramatically since going to Version 8; also there have been many Virus\Trojans that AVG has basically missed !
    Try Free Antivirus like Avast or Avira

    You have many (file missing) entries
    Usually these entries have come from doing a scan and having many Virus\Malware removed, thus causing the (file missing) entries

    I would suggest that you confirm your Java is up to date as well
    Please follow these steps to remove older version Java components and update.

    Download the latest version of Java Runtime Environment (JRE) 6 Update 7
    Scroll to Java Runtime Environment (JRE) 6 Update 7 and click on the download button
    (if you don't want the google toolbar -- uncheck this option before installing Java.)

    Click on the Accept License Agreement button
    Next Select your Platform and check the box that says: "I agree to the Java SE Runtime Environment 7 License Agreement.".
    Download Now! Windows Offline Installation, Multi-language

    Now close all windows, including your browser.
    Double click on the Java installation that you downloaded and follow the prompts.

    NEXT-remove all older versions of Java
    Go to Start > Control Panel double-click on the Software icon > add/remove programs.
    Search in the list for all previous installed versions of Java. (J2SE Runtime Environment.... )
    Select it and click Remove.
    Close any programs you may have running - especially your web browser.
    Repeat as many times as necessary to remove each older Java versions.
    Reboot your computer once all Java components are removed.
  10. digitill

    digitill TS Rookie Topic Starter

    OK, DTools gone.

    Damn it, I just uninstalled Avira since its realtime scanning doesnt seem to work, getting any decent anti virus tool to run on server 2008 x64 is a challenge in itself. For AVG, I had to even play around with a hex editor a little bit to get it to work, but the problems have started way before I installed it. Nevertheless, I will give Avira another try or go for Avast if it keeps refusing to run as intended. I do suggest taking AVG off the list u linked me to though, just to spare future readers the hassle:)

    Java has already been updated, its running version 6 update 10, guess thats OK;)

    Anything else?
  11. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Where did I link to install or use AVG?

    I hope I didn't, this program I remove every time I see it !

    Once you do this, there is nothing else, except confirm all system Drivers are up to date, and if you are game, you could run a Repair on Vista
    But you must then do all Windows security updates again (of which you should also confirm has been done)

    Otherwise, always do external backups (ie to CD\DVD or an external HardDrive)
    And let me know in a day (or whenever) if it faults again (after doing the above ;) )


    Oh I see it's in the 8 step proceedure
    I will see if I can get it removed
  12. digitill

    digitill TS Rookie Topic Starter

    Thats the link I meant, it lists AVG as one of the anti virus tools to install. But since that post is not yours I guess there is not much you can do about it;)
    Well, I dont know the repair options for windows server 2008 but my hopes are not very high anymore that this is actually a software problem:(
    There is no vital data on the drives so no backup is needed, the stuff I do want to keep is safe on 2 other drives and 2 external media, no worries there;)

    If you look at the problems again though, do you have an idea what it could be besides a faulty hdd? I mean firewalls and anti virus tools slowing the pc down, sure, but not to this degree. Any program I have installed that really conflicts with another or just doesnt want to be run on an x64 server platform? I dont want to seem conceited, but as I said I do this stuff at the university and have been doing it since I was 13 (wow, half my life...) and I really hope I am proficient enough to recognize obvious problems like malware, bogus torrents or driver issues.

    Well, Im off for today, will check back tomorow. Thanks so far.
  13. digitill

    digitill TS Rookie Topic Starter

    Meh, no change so far. Will let windows check the partition on next startup but I think it already did that recently to no avail (only "avail" would be some more sectors locked away I guess).

    So... any guesses besides the obvious?
  14. digitill

    digitill TS Rookie Topic Starter

    At the moment its really bad, every click takes many seconds to compute and at some point I just reboot. Only that even rebooting takes ages from the first sign of my desktop to windows actually having loaded the taskbar icons and background programs completely. And during all that really messed up behaviour process explorer or task manager shows me no extraordinary tasks running or anything eating away at the cpu or ram resources-.-
    Either C: is also in really bad shape (its on another hdd entirely, would mean both are crap) or I have no idea what could be causing this.

    Please anyone, I have no idea how to proceed besides checking HJT logs and task manager entries over and over and not finding anything :dead:
  15. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Please run Memtest on your Ram

    This also may be a faulty HardDrive, you could run a drive diagnostic test on it to confirm

    I would recommend that you backup first

    Also re-confirm that all your drivers are up to date, from your computer's (or motherboard) manufacture support page

    You can turn off any known not required startups using this tool:
  16. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    Visit tcp settings and verify you can resolve a name into an address, eg
    sometimes we see extraordinary times to get the address due to a timeout on the
    first DNS address and then waiting for the secondary to respond.

    If you get your DNS addresses with ipconfig /all
    you can then specifically test each with
    nslookup dns-address-1
    nslookup dns-address-2
  17. digitill

    digitill TS Rookie Topic Starter

    Yeah, on my way to letting memtest run overnight, just need sth bootable (or is memtest running during a windows session nowadays?).

    Only 1 of 2 tools from WD run smoothly on server 2008 and that one says all is fine. Will try again to use that data lifeguard tool you linked to though, maybe i hadnt tried that one yet.
    chkdsk already ran and reported no errors, but i guess i can run it again^^.

    Backup is no problem, both drives are practically virgin.

    Drivers were up to date 2 weeks ago and there were no problems up until a couple days ago, but maybe there is sth new available, who knows.

    Problems even show up in windows safe mode or whatever its called in english, so superfluous programs and services dont seem to be the issue.

    Well, I will be able to tell you more tomorow hopefully, maybe its really the ram...

    Interesting theory, but if i remember correctly i already tried disabling my network adapter alltogether and the problems were still there:( Or did i missunderstand you in some way?
  18. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    You certainly have 'issues', but the DNS / networking settings can be handled AFTER you get some stability. Revisit this when the system runs well
    AND if you have network lagging issues :)
  19. digitill

    digitill TS Rookie Topic Starter

    I dont even remember mentioning network lagging issues, you sure you are in the correct thread?:blush:

    Well, memtest ran for 7 hrs/12 passes tonight, no error, so its not the ram. Will let chkdsk have a try later today, after that im pretty much spent on ideas... and i dont think its a network issue, just to clarify;)
  20. digitill

    digitill TS Rookie Topic Starter

    Aaand another update. Chkdsk /f says no problem on any partition, so a hdd issue becomes less likely aswell...

    A few minutes ago I at least got a BSOD STOP: 0x000000F4 from windows, maybe that will help me somehow. I wouldnt even rule out a network adapter problem, especially given that F4 BSOD which is common for such issues, were it not for the fact that windows behaves crappy even in secure mode without network drivers even loaded.

    @ Joebeard: DNS works like a charm when I get far enough to test it...

    Any hints still very welcome btw:)
  21. digitill

    digitill TS Rookie Topic Starter

    OK, thats it, gonna wipe c: now. Its been a week fighting with this crap and itll take me only a couple hours to get a fresh working system from scratch. Plus, since ram and hdd dont seem to be the culprits after all it mustve been some forgotten driver or... irq issue or whatever.

    If someone knows what the issue was, let me know so i dont run into it again;)
  22. digitill

    digitill TS Rookie Topic Starter

    A very late PS:

    I am by now pretty sure it was the agnitum outpost firewall or one of its functions causing the stutters and crashes. After reinstalling windows with all the same software but another firewall (Look n Stop) I am not experiencing any problems.

    Maybe this helps ppl having similar weird issues with Windows Server 2008 x64 and using outpost.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...