1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Slow boot after xp sp3

By marymmcc ยท 4 replies
Nov 24, 2008
  1. XP Media Centre on Gateway MX6641 Pentium M laptop
    After upgrading to sp3, the boot time is very slow. I have traced it to 3 running processes:
    Cryptographic services
    Com+ system Application
    Net Run Time Optimization Service
    SP3 was installed with all startup services off.
    Apparently clean from virus/trojans (had been previously infected)
    Defrag done
    If I do not run these 3 services (above), boot times return to normal. Any thoughts? Can I disable these services? Should I uninstall sp3?
    thanks in advance
  2. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    Let's clarify things a bit as you have grouped two terms together that are not the same.

    Startup processes are what is checked on the Startup menu using the msconfig utility.

    Services are different. While the may 'startup', they are found here:
    Control Panel> Administrative Tools> Services.

    Some of these Services have to be set to Automatic Startup type, others can be set to Manual and a few others can be Disable. But 'startup processes' and 'Services' are not the same.

    The Cryptographic Service needs to be set to Automatic to start on boot.
    The Com+System Application Service can be set to Manual to only start if needed.
    The Net Runtime Optimization Service is installed with Visual Studio .NET.
    It may cause 100% CPU using in background. It shows as mscorsvw.exe is service precompiling .NET assemblies in the background.
    If you are using programs that use the ASPNET - MS Money for instance you will need this to run. Try setting on Manual Startup to see if there is any significant difference.

    Easy way to reset Services:
    Start> Run> services.msc> right click on the Service> Properties> change the Startup type. Always check the Dependency tab when changing a Service Startup.

    Good reference sites for Services:
  3. marymmcc

    marymmcc TS Rookie Topic Starter

    Thanks for your response. I understand that startup services and processes are not the same. My point was I did everything i could to make the installation of sp3 clean. However, sp3 has caused a slow boot.
    The services settings were already set to the commands you suggested. I'm now just thinking of uninstalling sp3 to get my fast boot back.
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

  5. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    We have different recommendation regarding SP3. Technically, if you got SP1, Sp2 and the updates up to the time SP3 came out, you don't need SP3. It was an inclusion of the previous updates, with little else that made any changes.

    I don't know what SP3 itself would cause the slow booting- it may actually be due to something that was included in the package.

    Uninstall it in Add/Remove Programs and check system status.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...