STOP Error 0xD1

By Route44 ยท 5 replies
Sep 6, 2006
  1. I have done extensive research on this Stop Error that falls under the DRIVER_IRQL_NOT_LESS_OR_EQUAL designation. It is like a plague (my system is only 4 months old). From what I have gathered, as per Microsoft, Logitech mice drivers are particularly cited for two earlier mouseware drivers, but it lists only earlier mouseware drivers causing the conflict. Now I do have a Logitech MX310 but I installed the latest mouseware driver version 9.79.1. I still get a BSOD and I have not found any further information if this mouseware corrected or failed to correct this issue.

    I also was able to write down the following from my last BSOD: ofd.sys - address A9D727FC base at A9D65000 Date Stamp 41107eb5

    I realize that may tell me what I need to know but I have never dealt with a BSoD before so I don't know how to rectify this issue; I can't say for certain it is my mouse driver.

    I gathered the following from the net but I don't fully understand it:

    The Stop 0xD1 messages indicates that the system attempted to access pageable memory using a kernel process IRQL that was too high. Drivers that have used improper addresses typically cause this error.

    I am sure my minidumps could give more information. How does one access these minidumps and how does one go copying them in order to post them?

    Thanks for your help.

    System Specs:

    XP Professional w/SP2 (32 bit)
    EPoX 9NPA+Ultra motherboard
    Athlon 64 3200+ Venice cpu
    2 Gigs of Crucial Ballistix PC3200 RAM
    X800 GTO vid card
    M-Audio 5.1 Revolution
    Logitech MX310 mouse

    NOD32 anti-virus, Spy Sweeper, Sunbelt's Kerio Firewall
  2. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

  3. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 11,984   +72

    Thanks, peterdiva, I hope I got it right.
  4. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    The culprit is fwdrv.sys, which belongs to Kerio Firewall. Either check for an update or uninstall it to see if the problem goes away.
  5. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 11,984   +72

    Man, you're good! May I ask what you read that shows it is my firewall and not something else? I am not questioning your answer, just trying to expand my knowledge. I have long expected it was my firewall (but I was also wondering if was my mouse or audio drivers). I think I'll try the upgrade first.

    Much, much appreciated peterdiva. Thanks tons. By the way, any firwalls you recommend that do the job, i.e., pass Shields Up! but aren't a system hog like ZoneAlarmPro?
  6. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    There's a brief tutorial HERE on what you need and how to read the minidump files.

    I've always used the free version of ZoneAlarm without any problems, so I've never tried any of the others. On the Shields Up site there's also a Leaktest you can run which checks for outgoing traffic, you should look for a firewall that also passes this test.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...