Strange wireless problem

By Flymayfian ยท 6 replies
Jul 30, 2008
  1. Hey there. This is my first post here.

    I had a short browse through and couldn't find anyone with the same problem as me.

    Here's the situation:

    I have a main PC running winXP downstairs that is connected to the internet through an ADSL router with a built in Wireless access point.

    I then I have a laptop running winXP which connects to the router using wireless. This wireless connection has been working fine for ages.

    I have recently purchased a new PC running Vista for use upstairs. It has a wireless PCI card. Heres where it gets complicated. The Vista machine says its connected to the router although I can't seem to get on the internet, or even view the router page (

    I have tried resetting and reconnecting all the equipment. I have also been through the TCP/IP settings on the Vista machine and compared them to the winXP laptop (which still connects with no problems) and they seem to be identical.

    I really can't see what the problem is.

    Thanks in advance for any help.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    you are going to have to look at the "Obtaining an IP Address" section in the network section of the Vista machine, This option shoud be set to automatic
  3. Flymayfian

    Flymayfian TS Rookie Topic Starter

    I assume you mean in the properties section of the connection and then the properties of tcpip? If so, yes they are all set to automatically obtain.

    I have just done the Windows Network Diagnostic thing on it (Something I should have done first really) and it says:

    Cannot communicate with Primary DNS server(
    Network diagnostics pinged the remote host but did not receive a response.

    Does any of that help?
  4. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Did you change the discovery options in Vista or did you leave it to the default. vista has the discovery map viewer if you can't see your router listed in this viewer then you have a problem. I ran into the same thing you're going through now.

    This is what I did...

    click on each one listed below
    1. Flag
    2. Network
    3. first network view every network pc should be listed along with the router if not let's continue on
    4. network and sharing center
    5. network should be private not public for one thing
    6. vista has IPv6 and IPv4 XP just had IPv4 (this allows you to change the DHCP)
    7. manage network connections (right panel)
    8. properties
    9 everything in their should be checked off, but if you're having issues you might want to uncheck
    10. IPv6 and just use IPv4.

    I use both and havn't seen any issues

    Now leave that popup open and go back to Network and Sharing Center

    Under the section called Sharing and Discovery (it should look like this)


    What does the full map view show?

    Should be your computer name, the wireless router or wireless access point and the internet globe

    Way below that are the list of PCs on the network.

    Make sure your wireless encyption is set to either WEP64-128bit if you have WPA/WPA2 use those harder for anyone to break into the WPA/WPA2 than it is with WEP keys.
  5. Flymayfian

    Flymayfian TS Rookie Topic Starter

    I left the discovery options as default.
    All the boxes are checked in the properties of the connection (IPv4,IPv6 etc) I have tried with just IPv4 and it still doesn't work.

    On the map its got: My PC ======== Router ----- X ----- Internet Globe

    I changed the options in the sharing and discovery to what you suggested.

    It seems to be doing something different than before but still says no connection to the internet.

    [EDIT] After changing the settings you suggested and and re-doing a Diagnostic check it all seems to be working. Thank you very much tipstir :)

    [EDITEDIT] Ok theres one last small problem: I am connected to the internet find on the Vista machine, but it says the wireless card is only connecting at 1Mbp. Not the 54Mbp's its capable of. My laptop runs at 54Mbp from the same position the Pc is at so I can't see the problem :S
  6. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Change the performance speed to 54Mbps for the wireless nic. To do this under Vista you need to go back:

    to network
    managed network connection (left panel)
    right click on your wireless network connection
    click on properties
    click on configure
    click on advance
    change Rate/speed whatever it's called to a Value: 54 (don't use best rate or etc)

    If you don't see this last feature mentioned then, go to your laptop maker web site and get the latest driver for that model.
    Note: You should see 5 bars all lit up green. If you're see less then your wireless connection signal is weak. To fix that you
    need to add wireless access point nearby. Otherwise the 54mbps won't be available always you'll see less than that.
  7. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    One more thing, don't let the wireless nic go into a sleep mode even if you're using battery. Because if you do it will cut out the connection and it might not comeback quick enough for the router to see the laptop. You might not have this issue I just notice that happens, but to fix that is to use a wireless access point bridge. Remember a solid connection better performance.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...