Taking ownership of a folder that is protected

By naike ยท 26 replies
Sep 22, 2008
  1. Hey, I had a folder with important stuff inside, and then i formatted my hdd.
    Now I cant access any of those files, and when i do the trick to go properties - security - advanced - owner etc.. i still cant access.
    Whats wrong?
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    That's right (you can't) because you formatted !
    Am I missing something here :confused:
  3. naike

    naike TS Rookie Topic Starter

    So theres like no way of cracking a default microsoft security ****?
    Not any?
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I'm sorry I don't understand the original question
    You will need to start again

    Describe the problem and your Windows version
    Describe exactly what you have done

    Please note, so far nothing makes sense to what you have stated
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  6. naike

    naike TS Rookie Topic Starter

  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Change the Security of the individual file as well (not just the folder)

    Actually I think you can tick the box that says subfolders and files (or what ever it says) which will update all the files in the folder as well
  8. naike

    naike TS Rookie Topic Starter

    Doesnt work its just green all the time, and i cancel the protection because access is denied.
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

  10. naike

    naike TS Rookie Topic Starter

    Yeah im using Windows XP pro SP2 (still hearing that SP3 isnt 100% bug free yet).
    I know, ive tried that trick many times, but it still doesnt work.
    Let me explain my problem again:
    I made a folder that contains important and secret information, i used the windows default feature to encrypt the files. The folder is on the same HDD, but in a different partition.
    Now I had to format my C: drive, and install windows again, after that trying to access the encrypted folder on the D: drive, it pops up a message saying that my access is denied.
    I tried to go to properties and revert the encryption, but again access denied.
    I tried to take ownership of the folder with using the security tab trick, just like in the guide you linked me.

    But its still just "Access denied" for me, even though it shows me I'm the owner of the folder.
    (I have tried to do the same thing for single files without success.)
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I believe the root cause for your problem is: account user names are just symbolic. It is just a nice human name to represent something called a Security Descriptor which defines/controls your access.

    When you created your files on other partitiion they were given the account name (and underlying security descriptor) defined in Windows. When you reinstalled you now have the same account name but a new security descriptor was generated which no longer matches the one for files/folders on old partition. And those are what's really used for permissions.

    When you followed taking ownership directions
    1. Did you make sure simple file sharing turned off? in Explorer, click Folder Options, View tab. Scroll to bottom and see that Use simple file sharing is unchecked.

    2. If the instructions are failing, which step is failing? what's the exact error message you receive?
  12. naike

    naike TS Rookie Topic Starter

    I have it disabled, Ill tell you exactly how i do this procedure.

    1. Right-click folder, Properties.
    2. Go to the Security tab, and click advanced.
    3. Go to Owner tab, then click the admin group, and check Replace owner on subcontainers and objects.
    4. Go inside the folder, and try to open any file inside it.
    5. "Access is denied"

    I also get the message if i use the same procedure on a single file.
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK... just a dumb basic question to make sure nothing is assumed

    Start->Run, lusrmgr.msc (that starts with "L")

    Click Users in left panel
    Then your login name in right panel. Rt click Properties. Click Member Of tab and what groups do you belong to?
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Let me know the result of above (what groups)

    I'm gonna guess you probably are in Administrator as assumed in which it's the encryption must be working its way into the algorithm of Security Descriptors and the process of taking ownership. I'd have to spend some time trying to look into it.... Tho maybe someone else might know what works in this situation.

    Otherwise, will keep an eye on the thread and be back to you when i can give u an update.
  15. naike

    naike TS Rookie Topic Starter

    Administrators and Debugger Users, I'm not that stupid to try taking ownership of anything without being admin. :p
    I'm looking forward for your reply.
  16. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    lol :)

    I really should put some time on this too

    I'll have to re-read and get back to you
    Obviously it's some simple service disabled in services.msc or Group policy setting in gpedit.msc, or a registry issuue in regedit

    In the mean time
    Can you just confirm all Windows files are intact by doing this
    Start-> run -> sfc /scannow (or is it on the command prompt??) Anyway you'll know

    You should also uninstall any live protecting programs like personal firewall or Spybots (which can stop certain registry changes if set incorrectly)
    But I prefer un-install fully to be certain

    Until then... :wave:
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    is never a matter stupid vs. we all make dumb mistakes (me certainly included)

    Since (i think ur still online) can give an update

    Did you make any backup of the system before you reinstalled? Apparently Windows creates encryption keys they advise are backed up and are needed to un-encrypt those files (which is why access is still being denied)

    Not sure if possible to work around that maybe. slight maybe... only a chance (don't know). might be lucky if you have the same physical installation CD as used last time
  18. naike

    naike TS Rookie Topic Starter

    I have a installation dvd.

    This is the result of the cmd you gave me.
    C:\Documents and Settings\Administrator>sfc /scannow
    Windows File Protection could not initiate a scan of protected system files.
    The specific error code is 0x000006ba [The RPC server is unavailable.
    I'll try to unload my fsecure, and then dc from the internet and uninstall the whole **** and try today, ill keep you updated.

    I really appreciate your effort in helping me.

    Edit: Didnt work to unload fsecure.
    But now i remember that windows update made hidden folder on my G drive, that i then tried to delete but Acces is denied popped up, I did the same trick and I took ownership of the folders so I highly doubt its the virus protection.
  19. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    NO, please hold off on that task!

    /**** EDIT ************/
    You say you have an installation DVD. Did it come pre-installed? i,e, you didn't use that DVD install disk before?

    Did you ever do a full backup of hte old installation?
  20. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    That's in Start-->Run-->services.msc
    Very easy to start, and place in automatic
  21. naike

    naike TS Rookie Topic Starter

    No this is a pirate copy of a windows xp sp2, which is created with some program, dunno the name but it basically includes programs that i can just check during the installation (and installs them, and no I never backed up anything, except some pictures and music.
    Should I enable RPC and try again?

    (I updated my previous post)

    Edit: Its not a OEM (i thitnk its called) that you get with pcs you buy off wallmart or something. e.e. HP, Dell, Acer
  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    There is NO indication that going through all your removal steps can have ANY affect on your problem - only potentially take it longer more difficult to get to your real problem source.: i.e. the XP encryption keys.

    Don't disturb the current environment until we figure out issues between encryptions and user attributes needed to remove encryption.

    Administrators DO NOT HAVE THE RIGHT TO REMOVE ENCRYPTION simply because they are Admins either

    This article describes how to decrypt a file that been encrypted by using Encrypting File System (EFS) in Windows XP.

    Encryption is converting data into a format that cannot be read by other users. You can use EFS to automatically encrypt your data when it is stored on the hard disk.

    Note Only the user who encrypts a file can recover data that has been encrypted, unless the user specifies a recovery agent before they encrypted the files. To make sure that you can decrypt files in the future, you should always export your certificate and private key and keep them in a safe location.

    For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:
    241201 (http://support.microsoft.com/kb/241201/) How to back up the recovery agent Encrypting File System (EFS) private key in Windows Server 2003, in Windows 2000, and in Windows XP

    Advanced methods to decrypt a file or a folder
    These methods are intended for advanced computer users. If you are not comfortable with advanced methods, you might want to ask someone for help or contact support. For information about how to contact support, visit the following Microsoft Web site:
    http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

    To remove encryption from a file or a folder, use the appropriate method later in this section.
    Method 1: Remove encryption from a file
    Only the following people can decrypt an encrypted file:
    • The user who encrypted the file
    • Any user who was designated as a recovery agent before the file was encrypted
    • Any user who has the public key or private key for the recovery agent or the user who originally encrypted the file
    • Any user who has been granted access to the file
    Members of the Administrators group cannot decrypt files unless the person who encrypted the files designated them as recovery agents before encrypting the files.

    Note You must be the original user who encrypted the file or a designated recovery agent for the file to follow these steps. If you are not authorized to remove encryption, you receive the following error message:

    Error Applying Attributes
    An error occurred applying attributes to the file:
    Access is denied
  23. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Hours I spent. Down the drain :(

    These copies have certain services disabled, written into the code
    ie they cannot be fixed!

    LookinAround is advised not to continue supporting this as well


    Thread to be CLOSED, no more replies of support please
  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I'm afraid am limited in assisting. (Which has everything to do with TechSpot terms of service.. Not kimsland's advice)

    For the what it's worth department, take a bit of time to go through MS support knowledge base searching for things like xp encrypt remove ownership

    You;ll find the ONLY fixes that apply are related have to address the XP encryption keys. Should be clear taking the time to read through a few.

    Bottom line: Is not 100% clear it would have been possible to figure a workaround for your circumstance anyway. (Even more impossible as you have an illegal copy that needn't play by the rules of XP and behave as we expect).

    Sorry. and good luck
  25. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    It is also against TechSpot's TOS to reply with any support replies
    Under this situation

    The reason is, TechSpot would be closed by MS for providing assistance to fraudulant users of their product

    I suppose seeming you said go to MS site,(as per your reply) it would be allowed
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...