The infamous SIS7012 problem.

By Poolboy ยท 11 replies
Feb 13, 2007
  1. Hey, I've been trying for yonks to get this working without any luck, and I've searched around the boards but to no avail, although there were many threads, and I know lots of people have had trouble with this (hence the title), so here I am.

    I recently bought a new harddrive and installed XP, everything went swimmingly, except for one thing, sound. Now I was having alot of trouble with it, when I had a break through, I was forgetting to turn the onboard sound on in the Bios, so I did that and thought it would work but it didn't.

    Anyway, long story short (and many hours later) I know what I have to install (the SIS7012) drivers but I'm getting that damn 536870397 error, and it just quits.

    Does anyone know how to fix this!?
  2. Boogityboo04

    Boogityboo04 TS Rookie Posts: 302

    The guy on THIS thread seemed to solve it by going into device manager and letting Windoze do the searching for the driver.

    Try uninstalling whatever you have done so far first.
  3. Poolboy

    Poolboy TS Rookie Topic Starter

    That doesn't work for me, it says it cannot find the driver, what's more is that while searching for SIS as a company I cannot find them.
  4. N3051M

    N3051M TS Evangelist Posts: 2,115

    onboard sound drivers belong with the motherboard. Find your motherboard's manufacturer's website (or if its a prebuild, that manufacturer like HP etc) then look through its download section for your mobo's model no.
  5. Poolboy

    Poolboy TS Rookie Topic Starter

    Okay I managed to install the drivers, the card was showing under the device manager, no problems, but I still wasn't getting any sound.

    Then, on restart, it disappears! I don't even have a 'Mutimedia device' listing with a littl '?' anymore, just nothing...


    Okay, update. I can find the SIS 7012 card (as 'Multimedia device') if I remove the RealTEK AC97 drivers, then I install the SIS 7012 drivers, and that works fine, but still, no sound.
    I have to re-install the ac 97 drivers, right? Wrong, that automatically causes the SIS 7012 to uninstall itsself and disappear again.


    Please help me guys, I've been doing this for 2 days straight and it's just turned 6 AM here and I'm at my wit's end.

    Okay, I just tried again, but before I installed the AC97 drivers, I disabled the SIS7012. When I installed the AC97 and restarted the PC, only the AC97 was left, as suspected, yet there was one crucial difference, it was disabled. That had never happened before. It was as if it is joining up and converging with the SIS driver, in some weird way.

    This is frustrating me. :(
  6. foozy

    foozy TS Rookie Posts: 139

    When I have problems like that with hardware, I find it much more satisfying to destroy the board with any number of heavy objects than to actually fix it.

    That being said, did the motherboard come with a driver installation CD? Is everything updated?

    Sounds like you've covered all the obvious bases, but might as well try anyway.
  7. Poolboy

    Poolboy TS Rookie Topic Starter

    I've lost the original CD. :(

    Shouldn't matter anyway, I'm installing the correct drivers, yet everytime I do it deletes the other half of the integrated sound card. I.e. If I install th AC79 drivers it deletes the SIS7012 drivers, and vice-versa.
  8. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    Try downloading the SoundBlaster kit. It's quiet large (~36mb) but the install
    allows 'Install Drivers Only'.

    It appears to be an intelligent install and just does the right thing :)
  9. Poolboy

    Poolboy TS Rookie Topic Starter


    I fixed it.:D

    It turns out I never needed the SIS drivers in the first place, I just needed to set it to 5.1 surround sound in the Sound Manager. Strange solution (which is why I never tried it earlier), but it worked. :D

    Woot. Thanks for the quick replies and the help, guys.
  10. Rat Barzane

    Rat Barzane TS Rookie

    wish that would work for me.... I tried installing AC97 drivers (i cannot get sis 7012 drivers to install at ALL) and it hasn't solved it for me :(
    at least now it says i have a sound device.... just can't use it! woohoo i can adjust non-existant volume!! lmao
  11. Rat Barzane

    Rat Barzane TS Rookie

    SIS 7012 almost working...

    Ok well that was a while ago... I've since gotten the (onboard) sound working if I change sound to 5.1 surround, plug speakers into one of the other jacks and set them to rear speakers... But not everything I want sound for uses 5.1... So I get no sound from them.
    Is there any way to change the stereo output to one of the other jacks? Because I don't know why, but I cannot get anything to work through the one its meant to work through lol... This is driving me nuts!

    Alternatively... if anyone knows how I can get the proper speaker plug working.. that would be awesome lol
  12. Rat Barzane

    Rat Barzane TS Rookie


    should I just start a new thread?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...