Timeouts & Other Network Issues

So this thread is probably going to have a lot of information on it, but please don't be discouraged, I really, really need help with some issues I've been having and if someone could solve this for me that would be amazing.

So, I've been experiencing timeouts. It seems I get timeouts whenever using some sort of wired connection. If I used an ethernet cable connected to my router, I would get timeouts in several applications such as Minecraft and Teamspeak. If I used Wireless, I was fine. So after lots of troubleshooting, I couldn't find a fix, so I've been using Wireless ever since. Lately however, my wireless has been unusually slow, not for everyone in the house, just for me. So what I did to solve the issue is I setup a D-Link DIR600 in my room to act as a Wireless Access Point. I now get slightly faster speeds and 5 bar connection, rather than the 2/3 bars I was getting previously. Now, I thought I wouldn't get these stupid timeout errors when connecting to this Wireless Access Point, turns out I still do. On Teamspeak for example; I will be talking to people and everything will be completely normal, I won't lag or anything, and then BOOM, I get disconnected. As I said, no lag, no warning, I just get disconnected. It's almost as though my router is randomly cutting me off.

So what I thought I'd do was replace my primary router (BoB Lite) with the D-Link DIR600, and then use Wired connection, because I assumed that the BoB Lite was causing the timeout issues. Now, I can't even connect to anything wired. I must have changed a setting when troubleshooting or something. But now I can't source internet from my laptop (ICS), and I can't connect to my original or new router wired. The only way I can currently get internet is by using the DIR600 in my room, but I still get timeouts when using applications such as Minecraft and Teamspeak.

So yeah, multiple issues. Firstly, if I could just solve the timeouts then that would solve everything, I could continue connecting to the modem in my room, and everything would be fine. OR, is there a way I could someone reset all my network settings that I may have messed up when troubleshooting? As I can no longer connect to any modem with a wired connection, not even the DIR600 which could have solved the problem.

If anyone could help me out that would be GREATLY appreciated. This is a really annoying issue and I've tried to troubleshoot it myself for ages now, but with no luck. IF anything in this thread doesn't make sense to you please tell me and I'll gladly explain myself.

Additional/Summarised Information: My primary router is a BoB Lite, my ISP is iiNet. The modem in my room is a D-Link DIR600. I'm using a NetComm N150 USB Adapter to connect to Wi-Fi. I'm using Windows 7 Ultimate 64-bit.

Thanks very much,


Get a command prompt
enter PING

does that timeout or return timing values?
Okay so apparently I can now connect to my original modem (BoB Lite) wirelessly! Unfortunately, it's still quite a slow connection, I switch between 2 and 3 bars signal, which is why I started troubleshooting and using the Wireless Access Point in the first place. I tried connecting to the DIR600 with a wired connection, but it just says I'm connected to an Unidentified Network, and that there is no internet connection. I also can't access 192(dot)168(dot)0(dot)1 in my browser, isn't that the control panel for D-Link routers, therefore I should be able to access it?

Windows also said that it found a problem 'Local Area Connection doesn't have a valid IP configuration' when I tried to connect to the DIR600 with wired, but I'm not sure if that's actually right.

Get a command prompt
enter PING

does that timeout or return timing values?

I ping'd it while connecting to my BoB Lite with ethernet (which gives me timeouts), but I didn't get any timeouts in cmd. It returned timing values.
Can I get any more help? I've tried troubleshooting that router for a while but it doesn't seem to be working. But now I want to solve a different problem, one I stated in the original post.

I'm trying to connect to the DIR600 modem via ethernet, but it doesn't work. I can connect to it, but usually it says 'Unidentified Network' and I can't get any internet access. Why would this be?

Any help is appreciated, thanks.