Toshiba Satellite USB problem

Not open for further replies.
Hi, please help,
While sat using the laptop the other night i suddenly had a yellow box appear in the bottom right corner telling me that the USB device could not be recognised. At the time there was no device plugged into any of the ports. I tried to troubleshoot to see what was going on but nothing got resolved so i rebooted. Still happened after restart still with nothing plugged in.
I have tried everything i know to resolve this problem. Checked device manager, all 3 usb devices are saying that they are working correctly and there are no red or yellow marks next to them. I have uninstalled them and rebooted, same problem. Now none of the 3 ports will work at all. Tried various devices in each of them and nothing except for residule power that will turn power lights on if the device has one.
Not sure if this is linked but tried to enter bios just to check settings but what i know to be my password no longer works. I HAVE NOT changed it and nobody else has access to have altered it either. I have tried backdoor passwords and they wont let me in either.
Please help, this is driving me nuts.


Posts: 5,746   +14
possibility the connector is loose internally.
Have you also done a virus/ trojan check lately?
Well, this has got to a point now where i am just going to format and hope to god that works.

I have done a virus check but with Norton that came as part of my isp bundle, so not sure its checking thoroughly enough as a full programme would. So, being the case i tried to put MacAfee total protection 2007 on to thoroughly check the laptop but you know whats coming now-cant put it on because Norton is there. So, walk into the problems of not being able to remove Norton and decide to go another way to solve problem. At the moment i have bridged the problem-PCMCIA to 4 USB port card. And yes, it does need a usb port for power so i am having to use 2 laptops, this one as normal and another next to it just to plug the power cable into, lol. Im going to utalise this to get all files onto mem card and wipe this hole system and start again, hopefully with working usb ports, bios password cleared and no Norton on the thing.
judyhodge, this is known problem for l35 series. first af all, you need to reflash the bios. be careful, flashing may will fault, this is because of errors, connected with certain type of bios chip and flasher. best way to reflash bios is external programmer. after reflashing, and if all as good. the problem has solved. but if usb ports still won't work - this is southbridge failure(ati ixp400).
Not open for further replies.