Tower light is on, no signal to monitor

By workmen
Apr 18, 2013
Post New Reply
  1. I was trying to download a Photoshop action when I instead downloaded Mipony. I immediately went and uninstalled it. It listed 3 components Mipony, webjam and something else. I unistalled each from the control panel uninstall place. It told me that I had to reboot to complete the uninstall. I selected to go ahead and reboot. Windows shut down and my monitor turned off but I'm not sure if the tower went completely off or not. After it sat with the light on and doing nothing for at least a full 2 minutes I turned it off manually. When I tried restarting it the light came on it made a few noises and the fan started, no monitor. I tried turning the monitor on manually and it says it has no signal. I have tried the connecting cord at least 4 times but it is all attached and tight enough.
    I have no clue about computers... help?
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "I have no clue about computers... help?" All the advise we have for this is to take the computer to a shop or friend that knows how to repair computers

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...