Unable to access external hard drive

By wuanju
Apr 11, 2009
  1. I have a Buffalo Drive Station 1TB External Hard Drive. I've used it for three months w/o having any issues w/ it until yesterday. As usual, I plugged it in my pc and waited for it to automatically run. (my os is an xp pro servicepk3 btw) While i was waiting, my I.E. froze, and i got the blue screen of death. After restarting my computer, I tried plugging it in again and it will read, but i just can't access it. It shows up on the bottom right corner where i could 'safely remove it' and when i open up 'my computer' the icon appears as a normal drive (it usually has its specific icon and name) but i can't click in to it. When i attempt to click it, my computer goes in to a long lag. I tried everything i could possibly think of, unplugging the cables, reinstalling the driver, using different ports, etc. Any other ideas?
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The Master Boot Record (MBR) may be corrupt. You may have to format the drive again, loosing any data on the drive
  3. wuanju

    wuanju TS Rookie Topic Starter

    thanks. but is there any way to recover the mbr of the drive?

    do you think if its possible if i used dos to
    chkdsk l: /r and fixmbr?

    i know thats one way to fix the mbr when c: drive is corrupt.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...