Unable to log off or shutdown in 2k

By videobruce ยท 6 replies
Apr 3, 2003
  1. I always seem to get the 'weird' problems.

    Running Win 2k w/sp3 I have a box set up with one user and using TweakUI I set it to login with that restricted user automatically.
    I changed the startup of some services in Administrator Tools to trim down what is running at startup and now when I try to log off to get into the administartor destop, shut down or do a restart I get a CSC notification window stating that a program (don't know what) isn't responding. Either way, waiting or checking 'end now' explorer quits and all I see is the destop wallpaper. Ctl-Alt-delete doesn't do anything and the windows key doesn't either. I can't shutdown, restart or even logoff! All I can do is power off from the computers power button.

    I tried going into safe mode, but since it is set up as a restricted user (I guess) I still don't have all the tools and access to the desktop or even all of TweakUI's controls in safe mode! In other words I'm locked out of doing anything either in safe mode or trying to get into the administartor screen.

    I don't know what program isn't responding since Task Manager shows NO program running and only 13 processes running (including task manager itself). There is one Windows process that is running that I have NEVER seen before (no, it isn't a virus!) called: "dmadmin.exe" which I assume is the problem, but I can't end it from task manager since it I'm in a restricted user screen. Also, when I do go into safe mode it takes much longer (or so it seems) to boot.

    This is a older box and the purpose of trimming down the services was to speed up the system since it is only a 233MX processor. I have used the services consel many times and use it instead of MS Config to stop services from loading at startup. I also am aware of Black Vipers site on M$ services which I use as reference in using the services consel. In other words, I am familar with this tool, but got a M$ kiss this time!

    I hope all of that makes sense.
  2. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

    Well you could always try the second repair option on the Win2k install disk as a second-to-last resort. It leaves your registry and applications intact but you will have to re-install service packs and hotfixes. Sometimes it works, sometimes it doesn't for things like this.
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Open Task Manager, kill Explorer process.

    Open File->New Task
    type "runas /user:administrator explorer" and click OK

    MINIMIZE the Task Manager, do not close it or you may crash the machine!

    Enter the Administrator password in the runas command prompt window.

    You should now have desktop access with admin rights.
  4. videobruce

    videobruce TS Enthusiast Topic Starter Posts: 93

    I looked through M$'s KB and found this:


    Well, my little secret worked again..........

    All my boxes I setup a 2nd bootable drive. I swapped jumpers went into that drive, renamed 'dmadmin.exe' in the System32 folder, reset the jumpers and presto, got into the administartor screen and edited the registry.

    All is fine.



    For the heck of it I tried that, but the command prompt doesn't respond to the keyboard input. All the cursor does is flash!
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    For security reasons some programs do not display asterisks for password characters. This is the case with runas, you just type the password and hit enter.
  6. videobruce

    videobruce TS Enthusiast Topic Starter Posts: 93

    Ok, nice to know. I understand that the password doesn't show, but there is no indication that the command prompt box is even responding! Another Lamo on M$ part!

    Anyway, I retried that and nothing. Explorer didn't start. Task Manager is still there though.
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Sure works for me, after you have typed the password and hit enter, the program specified will run or the runas box will close (if the command box is responding of course).
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...