1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

VAIO PCG-7184L, freezing at Win7 logo, safe mode freezes on hal.dll

By t1z ยท 7 replies
Jan 21, 2012
Post New Reply
  1. Hello my fellow techies!!

    I have spent the last few days working on my friends Sony Vaio PCG-7184L(which by the way is not listed anywhere on sony's website). It runs windows 7 64bit and it freezes immediately after the Windows logo starts it's animation and there's about an inch of the top of the screen that is filled with weird colored lines. So I told him sure, I'll fix it, it's probably just a virus and should be fairly simple. I will list in sequence what I have done so far to diagnose/fix the issue. One more thing, it started doing this freeze up thing the same day he got it back from the Geek Squad at Best Buy, who were doing a simple update and cleaning from what my friend told me. OK, here's what I did...

    1. Tried booting into safemode, froze, on hal.dll, with same colored lines at top of screen
    2. Tried booting into ERD Commander 2k8 and froze at the same spot.
    3. Booted into Linux live CD and scanned for viruses with avast, there were none.
    -This is when I looked at his hard drive capacity and realized that only windows was installed, Best Buy must have wiped everything and not told him.
    -OK, no viruses, so I'll run hardware checks
    5. Found a place to d/l the windows 7 64bit repair disk and ran it only to have it tell me that it can't automatically fix the problem, followed by a report as to which tests were successful and which were not.
    4. Booted into Hiren's Boot CD and ran every hardware tester available and all came back clean.
    -I remembered seeing three partitions on the Hard Drive while I was in Linux which lead me to my next step.
    5. Using Hiren's I booted into the "Repair" partition, which was installed by Sony before my friend purchased the laptop.
    -Excellent, I have access to the manufacturers testing tools and restore software.
    6. Ran even more tests on both the hard drive and the CPU, just to be absolutely sure.
    -At this point I decided, since Best Buy already deleted all my friends music files, I will just set the computer back to factory defaults with the restore computer option.
    7. Ran the restore computer option and it successfully completed at 100%, then rebooting the computer and as soon as that windows 7 logo animation started BOOM!!! frozen again!!!

    And this is where I am stuck, normally I would think that it must be the graphics controller because it's the only thing I didn't have testing tool for. But, thinking more I remembered that I was able to run the Linux Live CD for over an hour with no problems with video or anything. I can't believe that setting it back to factory defaults didn't fix it. Could it be some kind of crazy rootkit or damn, I don't even know what to do next. I suggested to my friend that if I can't get windows 7 working again that I would try to do a full install of Ubuntu on there for him since he only surfs the net and listens to music it should be fine for him. Please if anyone has any suggestions of what to try next I am all ears, and thank you all in advance for wanting to help.

    P.S. Sorry for the super long post, I just figured the details would be useful

    OK, back again. I decided to download a fresh hal.dll and replace the one which seems to be failing and now I get this error even before getting to the windows logo. It says:

    File: \Windows\system32\hal.dll

    Status: 0xc0000359

    Info: Windows failed to load because the HAL is missing, or corrupt
  2. t1z

    t1z TS Rookie Topic Starter

    So I just ran the windows repair disc again and this is the Startup Repair problem details:

    Problem Signature:
    Problem Event Name: StartupRepairOffline
    Problem Signature 01: 6.1.7600.16385
    Problem Signature 02: 6.1.7600.16385
    Problem Signature 03: unknown
    Problem Signature 04: 886
    Problem Signature 05: ExternalMedia
    Problem Signature 06: 1
    Problem Signature 07: FailureDuringSetup
    OS Version: 6.1.7600.
    Locale ID: 1033

    This is the Diagnosis and Repair details, I have to type all this up by hand so I excluded everything that was successfully tested:

    Number of repair attempts: 1

    Session Details
    System Disk = \Device\Harddisk0
    Windows Directory = D:\Windows
    AutoChk Run = 0
    Number of root causes = 1

    Root cause found:
    Failure while setup is in progress.


    These are the tests that were successful all with an error code of 0x0:
    Check for Updates
    System disk test
    Disk failure diagnosis
    Disk metadata test
    Target OS test
    Volume content check
    Boot manager diagnosis
    System boot log diagnosis
    Event log diagnosis
    Internal state check
    Boot status test
    Setup state check
  3. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    You need to check or replace the laptops memory...
  4. Ranger12

    Ranger12 TS Evangelist Posts: 620   +122

    It can only be attributable to human error!

    Sry, couldn't resist after seeing it was a "HAL" error. Anyway...Yah I agree, check the ram.
  5. t1z

    t1z TS Rookie Topic Starter

    rams fine guys, like I said I checked, double checked, and triple checked everything but the gpu
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    This is a laptop right?. The missing HAL.dll is a symptom not a missing file problem

    "I can't believe that setting it back to factory defaults didn't fix it"...

    This is a very good clue that there is a hardware fault causing all this
  7. t1z

    t1z TS Rookie Topic Starter

    I concur. However, we've been running Ubuntu 11.10 on it for a few days now and its been running like a dream. I too think it's hardware, but at the same time it doesn't seem like it. Now as far as the hal.dll thing goes...I did some reading and most times when a system freezes on a specific file like that it means that the last file showing wasn't the problem, instead it's whatever tries to load immediately after that file which is causing the problem. I could very well be wrong though.
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    How about still replacing the RAM? It just might be a Windows compatibility thing

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...