Vista not detecting Nikon driver?

By waterproof ยท 25 replies
Jan 5, 2010
  1. I have a nikon slr camera (d60), i want to transfer files from my camera to my computer, but it seems to me my computer could not detect it any more, I had Vista Sp1 then and it worked fine, it was until I updated to sp2 I could get it to work, i get a message saying installing driver denied or something, any solutions?
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Did you ever install any special software or drivers for your cam? (e.g. did it come with an installation CD when you bought it?)

    I'm wondering if there's more information available from the error message.
    > Does it refer to a specific file or driver?
    > Could you quote the exact message and is there an error number ? (or if easier, just do a screen capture and attach to your next post)
  3. waterproof

    waterproof TS Booster Topic Starter Posts: 208

  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I'm guessing your problem is either
    > Related to a problem fixed by an earlier MS hotfix
    > Or, more likely, the Nikon driver installation includes one or more unsigned drivers files. Vista doesn't normally allow unsigned drivers to be installed

    1. Apply an MS KB
    > Tell me if you're running 32 or 64 bit Vista Click for how to determine whether you are running 32 or 64 bit windows
    > If you are 32 bit Vista, try this MS KB
    > If you are 64 bit Vista try this MS KB
    Note: The dates of these KBs pre-date the release of Vista SP2. So it's possible this fix is already included in SP2 and Vista will tell you they don't apply. But to be certain, try it anyway (it won't hurt to try and see what Vista does)

    2. Generate a report of signed and unsigned drivers
    See How to identify unsigned drivers using sigverif utility Attach the SIGVERIF.TXT file to your next post

    3. See if you can locate the Nikon driver files in Device Manager
    Try the install so it generates the error message window. While the message still appears, open Device Manager. Look for the camera's entry in Device Manager. Does the camera appear?
    > It'll probably be called Digital Still camera
    > It'll probably have a yellow or red icon appear on the entry
    > Rt click it, select Properties. Click Driver tab. Click Driver Details
    > You'll now see a list of one or more driver files
    > Select each one and look at the Digital Signer file info displayed below. Do any files say Not digitally signed? Tell me which ones
  5. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    Thanks, I've tried and it won't let me it says it does not apply to my system, there was no other option that lets me do it otherwise, it just closes the diagram and clicking ok.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Yea, i guessed was most likely that fix only applied to Vista SP1. It's already included in SP2 (which you have installed)

    So best guess still is an unsigned driver is causing the problem. Could try the report (step 2) and see if you can see the camera and its driver files (step 3).
  7. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    Ok for step 3, It was under Portable devices > Nikon D60 (with the yellow small icon thing on the device icon as well) > right click as what you said, the box says 'No driver files are required or have been loaded for this device'. The portable devices icon actually disappears when I remove the camera, of course.

    and I have attached the sigverif as well

    Attached Files:

  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Darn.. nothing is jumping out at me from that list.. maybe there's something else going on...

    Let's try this. Look for file C:\Windows\inf\
    > This is a Windows log file of Plug and Plug device installation activity
    > Why don't you rename it e.g to C:\Windows\inf\
    > Then insert the camera so Windows tries to install it (windows will create a new trace log)
    > After the error message remove the camera
    > Then attach a copy of the trace Windows created in C:\Windows\inf\

    Maybe that will have some clues and be more useful...
  9. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    Ok I have attached the file as followed in the instructions you gave.

    Attached Files:

  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Well, the trace shows the driver file Windows was working on (which at 1st glance seem just fine) until the install process just fails Access Denied.

    If you go to Control Panel->User Accounts double check that your userid has Administrator privilege?
         ndv:      Installing device...
         dvi:      {DIF_INSTALLDEVICE} 02:53:18.783
         dvi:           CoInstaller 1: Enter 02:53:18.787
         inf:                Opened PNF: 'G:\Windows\INF\wpdmtp.inf' ([strings.0409] <src=drvstore>)
    !!!  dvi:           CoInstaller 1: failed(0x00000005)!
    !!!  dvi:           Error 5: Access is denied.
         dvi:      {DIF_INSTALLDEVICE - exit(0x00000005)} 02:53:19.401
    !!!  ndv:      Error(00000005) installing device!
  11. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    Yes, I have permission, I'm the administrator on my own computer lol, I haven't got any other user accounts created
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Well... i can try looking into it more a bit later... but as of right now, this has me stumped :confused:
  13. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    I understand, and I highly appreciate all the help you gave and I thank you for that, this had me also stumped as well, all I know is that this problem started only after I updated my vista with SP2.
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

  15. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    I have, the program does not detect the Nikon camera for some reason and I still get the same error. Also to add; I'm not sure what's the problem, I dual boot with Windows 7 and I have no problems with installing the driver. Another Vista headache, but I am willing to get to the bottom of this issue anyway.
  16. captaincranky

    captaincranky TechSpot Addict Posts: 12,982   +2,527

    Why not try rolling the computer back to the date before SP2 was installed.

    It's a tad bothersome but at least you'd affirm or eliminate SP2 as the cause.

    I'm sorta lazy, and I suppose I'd rather have the camera working than Vista with SP2.

    Actually, since I always save to card, and don't use the USB cord, I've never even bothered to install the Nikon software. Some of the software with the camera kit disc is a trial version (!) or (!)

    Since I use Photoshop elements version 5 & 7, both of which have updated camera raw plug-ins for my D-90 (&80) I just bring the files in directly to PSE.

    I know there might be some issues with the movies also without the Nikon software, but good lord, have you seen the size of those instruction manuals?

    This is probably stupid but, I know you're the administrator on your own machine, but have you right clicked of the installation .exe files and selected "run as administrator? (If you have, please overlook that I mentioned it).
  17. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    I was thinking of the same thing; but the problem is I deleted the restore points from my computer using TuneUp utilities to have more disk space. I think if I could not get this issue resolved, I could just do an upgrade to Windows 7, but then again I have the headache of a long installation process, and I've already got Windows 7 as dual boot 64 bit and much prefer using Vista (32bit), for the sake of what I have already installed, I hate installing over and over when it comes to software.
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    A few more notes:

    1) Was the Nokia s/w first installed in SP1 and then you updated to SP2? You might try
    > uninstalling all the Nokia software
    > reboot
    > then try a fresh reinstall again now under SP2

    2) Nikon uses some newer data protocols: MTP/PTP (Media Transfer Protocol/ Picture Transfer Protocol) to transfer its data.
    > Vista is supposed to have built-in MTP/PTP support (that's a good laugh, huh?... or cry... depending on your view!)
    > So, fyi, at least its consistent to see Vista trying to install the wpdmtp.inf when the problem occurs (i.e. the mtp/ptp protocol drivers)

    3) Check one other thing: When the camera is connected look at all the Portable and Removable devices listed under My Computer. Does the camera appear? Try clicking to open it. Can you at least access the camera storage as you would an external USB drive?
  19. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    I have done all that already, and as for step 3 you suggested, i couldn't find it and it's not displaying, before it used to display, and i didn't really need to update my driver (this is with sp1). What's interesting, is that I have a usb stick, which I use for external storage backing up stuff, is that it shows up in my computer, but the driver update also fails for some reason. When I want to update the driver (via microsoft) it again says access denied. I'm not sure if that's reverent. Anyway, do you think if editing the registry or something along that line would help? I don't know if this issue would be related to the registry but I am trying to think other solutions lol.
  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Am I understanding your last post correctly that it doesn't seem you can install any new USB device (the camera USB install fails as well as when pluggin in a new USB flashdrive?). In each case you see Windows triy to install a driver and but it fails with "Access denied"?

    What antivirus product are you running on your system. Do you know how to disable your antivirus real-time protection mode? Try doing so

    /* Edit */
    And do you have install / recovery CDs in the event it comes down to trying to rollback SP2 (as captaincranky suggested) or even do a full clean reinstall?
  21. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    The symptoms you describe all point strongly to a USB problem. This could be software or hardware, but if I am following you, you can dual boot to Win7, where USB (and the camera in particular) work fine. Yes? not hardware then...

    In which case, you could look into totally refreshing the USB configuration in Vista. This has been covered well on this site, can't find the link right now though. to see the current config. simple reconfig. possibly relevant from MS
  22. captaincranky

    captaincranky TechSpot Addict Posts: 12,982   +2,527

    Does Vista SP-2 have a complete "KB" designation of its own? Because if it does, then you would just use the control panel to uninstall it, no need for a restore point being set.

    This is just one of my opinionated rants but, before I'd allow my restore points to be deleted, I'd buy a bigger HDD and leave them right where they are. Sorry for that.

    The only prudent deletion of restore points is usually in the event of malware recurring after attempting a cleanup.
  23. waterproof

    waterproof TS Booster Topic Starter Posts: 208

    Yeah it's not hardware issue, since I have no problem with Windows 7.

    I have looked at this what you have given me;

    although I have no issue in relations to USB not working via hibernation, the part below of the screenshot I took is interesting;
    could it be edited or anything with registry having to do with this issue?
  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I'll offer the following comments

    > I don't believe there's any indication your issue is misbehaving hardware.
    > There's every indication your issue has to do with permissions in Windows

    I also found there's many, many people who've had a similar problem.. though no solution. even including (look here) in our very own TechSpot

    Just a guess.. but as mentioned before, you should start by disabling your antivirus real-time autoprotect settings. I've seen this feature interfere with normal OS function in the past and i think is a good candidate to rule out.

    and to clarify, did you say you have install problems with other USB devices as well? or is it ONLY the camera??????
  25. tonylukac

    tonylukac TS Evangelist Posts: 1,372   +69

    Try going to Control Panel->User Accounts and disable uac. Then, reboot and uninstall and reinstall the drivers.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...