Why is my keyboard typing wrong characters

jo233

Posts: 22   +0
I have a logik keyboard for pc and this what my keyboard gives instead

q gives `
w opens 'help' box on whatever programme is open
r gives 5
u gives 6
I gives =
p gives -
g gives b
h gives n
; gives '
' gives /

how can this be solved?
 
Last edited by a moderator:

jobeard

Posts: 13,831   +1,749
Is this an International KB, aka European? and/or what LOCALE have you set in the Control Panel -> Region & Language?
 

Bobbye

Posts: 16,321   +36
Two more possibilities:
1. Numbers Lock may be on:
Press the Num Lk key to release. Does that get the characters back into the right key?

My cat walked on my keyboard, apparently pressing that key. It took me a while to figure out where all the havoc it created came from!

2. Sticky Keys may be enabled.
Press Shift key 5 times in a row. -or-
Press Ctrl + Alt> then Shift key once or more as needed.
 

jo233

Posts: 22   +0
  • Thread Starter Thread Starter
  • #5
Keyboard is working. I tried a few different suggestions. not sure which solution fixed it though.
 
G

Guest

I am having a similar problem with a Logitech wireless KB (TK 820). The only temp fix I have found so far is a restart, wish fixes for a short time ( 2-3 days) before I get random changes in the response when I type).
 
G

Guest

The keyboard might be set for English (US) or something similar instead of English (United Kingdom). Change it to the area you live by using the Control Panel. Worked for me.
 
Keyboards which do not have a number keypad, use the Numlock button to convert almost the whole right side of the board, into a number pad.
While in that mode, one can use the Fn button, to toggle between using letters or numbers.
To stop using the right side of the board as a number keypad, press the Numlock button to shut it off, getting the letters back.
 
I know this is an old thread, but this was the closest hit to my problem when I searched.
My keyboard was giving me "om" when I pressed "o" or "m". It did the same thing on many PCs. I couldn't find any solutions online, so I figured I should open it up and check it out. I cleaned the inside a little, and gave the plastic membranes (in my rubber dome switch K400) a little wipe down. It didn't seem to work at first, but I tried again in a while and the problem went away. So I'm not sure what fixed it, but I guess it wouldn't hurt to open it up and clean and jiggle the parts around a bit. Just be careful not to snap any little ribbon cables while you're at it.
 
  • Like
Reactions: holdum323
I think I inadvertently hit a couple of keys at the same time on my Logitech keyboard for my iPad, resulting in
t—> /t
. —> ^
and more...

None of the solutions above worked for me. I finally took the batteries out, and a few hours later put them back in. Now it works fine.
 
I know this is an old thread, but this was the closest hit to my problem when I searched.
My keyboard was giving me "om" when I pressed "o" or "m". It did the same thing on many PCs. I couldn't find any solutions online, so I figured I should open it up and check it out. I cleaned the inside a little, and gave the plastic membranes (in my rubber dome switch K400) a little wipe down. It didn't seem to work at first, but I tried again in a while and the problem went away. So I'm not sure what fixed it, but I guess it wouldn't hurt to open it up and clean and jiggle the parts around a bit. Just be careful not to snap any little ribbon cables while you're at it.
@BrandonY I just wanted to thank you for your suggestion. I had the exact same issue: typing "o" or "m" would show up as "om", and "f" was mapped to a right click. 7 was 7 and another key. Really annoying. I took the whole keyboard apart and cleaned each layer of the circuit membranes with a Swiffer cloth. I disconnected the power cable by mistake but was thankfully able to squeeze it back in properly. Totally saved me from buying another keyboard. Logitech K400R keyboard is now back to working perfectly.
 
Guys you have to open up your keyboard and clean it.it worked for me. I have tried each and every step mentioned above, but nothing works. Hope it helps you
 
I have a logitech K800. Spilled some coffee on the keyboard and had the same problems as the threads above. For example, when I typed "a" I got "a/"

To fix, I disassembled the keyboard and wiped everything down using a shammy cloth. I would recommend a dust attracting cloth if you can find one. I set the keyboard in front of my fan overnight. I reassembled this morning and problem solved.