Win 7, WinRAR

By nickc ยท 18 replies
Jul 29, 2010
Post New Reply
  1. Ok I am running Windows 7, and have wirar program all u needed to do to run it in XP was click the icon I placed on the desk top, but in Win7 it says to right click and set to run as admen. could some one tell me how to do this.

    the program I am trying to run is Realtempt_2.70
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

  3. nickc

    nickc TechSpot Paladin Topic Starter Posts: 923   +11

    well that was of no help. what i need is to know how to right click the icon and give myself admin rights and I can find no place to click to do this, and I am the only one here so I am the only one that can run it.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Well, does your userid have admin privileges to begin with???? If not, you can't simply assign yourself admin rights.

    if you do, then Option Two in that link should apply. When you rt click on the excutable, you should see Run as Admin

    Or is that not working either???

    /* edit */
    Corrected "admin rights" to "admin privileges" in first sentence
  5. nickc

    nickc TechSpot Paladin Topic Starter Posts: 923   +11

    Yes it does there is no where to click. and yes I have admin rights. when I do the ctrl shift nothing happens.Let me give u a little more about me and this computer. It is new, not the processor, I am using it form another machine which I put another processor in. for the biggest part I try not to lose anything, i run two hard drives so I can reinstall windows and reinstall programs without down loding any thing again. this program reads the tempt of the processor and sits by the clock, I have had it down loaded for several years but it is the best at what it does that I can find and is recomended by many. all u do is drag the icon t the desktop and click it every time u boot. and yes I built the computer and Installed windows myself. if there is any thing else u would like to know just ask.

  6. Zilpha

    Zilpha TS Enthusiast Posts: 319

    You might have to right click on it, go to Properties, and then the Compatibility tab and check "Run this program as Administrator". You might also want to try the XP compatibility mode if it's not working in Win7.
  7. example1013

    example1013 TS Enthusiast Posts: 265

    Okay, here's the deal. You don't need to give yourself admin rights, you need to give the program admin rights. That's what "Run as Administrator" does.

    I'm slightly confused here, though. Are you saying that the program has no option for "Run as Administrator"?
  8. Zilpha

    Zilpha TS Enthusiast Posts: 319

    I *think* he means that there is no "Run as Administrator" in the right-click menu. I've seen this before, but only a handful of times. That's why I suggested that he go to properties and try to select it there.
  9. example1013

    example1013 TS Enthusiast Posts: 265

    Hopefully, if there is no "Run as Administrator", using Properties works.
  10. nickc

    nickc TechSpot Paladin Topic Starter Posts: 923   +11

    That is exactly what I mean, but I am talking about when in right click. If I go to securty I am set as the Administrator. what can I do from here?
  11. Zilpha

    Zilpha TS Enthusiast Posts: 319

    Is there no Compatibility tab?

    Please perform the step I described in an earlier post and let us know how that works out.
  12. example1013

    example1013 TS Enthusiast Posts: 265

    You need to go to the "Compatability" tab and click the checkbox for "Run as Administrator".

    Windows 7 is a bit different, as far as program permissions are concerned.

    There are now two types of programs: administrator programs and user programs. Administrator programs have administrator privileges. They can do administrative actions by default.

    User programs don't have these permissions. They just have regular permissions. So user programs won't be able to do administrative actions, even when run on an Administrator account, unless you elevate their permissions. "Run as Administrator" elevates the permissions so that a user program can do administrative actions.

    So basically, the program itself, not your user account, needs to be granted administrative permissions. Which is why it's a problem when there's no option for "Run as Administrator" when you right-click. It should be under the "Compatability" tab, though.
  13. nickc

    nickc TechSpot Paladin Topic Starter Posts: 923   +11

    no, it does not have a Compatility tab
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I don't have the answer. Just a couple suggestions

    1) On the one hand, it might be helpful to provide screen shots of just what you are seeing (as we're all clearly expecting you to be seeing something else)

    2) It might be worth getting yourself checked for viruses/malware 'cuz is mighty odd (maybe suspicious) if those Admin choices have disappeared if your userid does have admin rights. Virus/Malware removal Instructions

    Other thought is try running a Windows repair
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OH. Also, look for Compatibilty tab on the actual file not the shortcut. Also if you're trying to run via a shortcut, try all the suggestions from the file not the shortcut
  16. Zilpha

    Zilpha TS Enthusiast Posts: 319

    Ok, I think that we need to take a step back here for a moment. Here's what I understood from your post

    1. You are running Windows 7
    2. You mentioned Winrar, though I don't see how this is relevant
    3. You are trying to run a program called RealTemp 2.70

    Now, my first question is have you extracted the files to the location you wish to run the program from? You can use either Winrar or the utility that has come with Windows for time out of mind now.

    This Real Temp program is in the .zip format, and I was able to download it from their website, unzip it, and execute the program. Of course it doesn't work on mine because apparently it doesn't support AMD, but that's another story.

    The only way you would be missing the compatibility tab and the Run as Administrator is if you are trying to right click on the Zip file itself in which case you will not get the desired results.
  17. nickc

    nickc TechSpot Paladin Topic Starter Posts: 923   +11

    OK, I will try to answer u'r questions yes I have winrar, actually winrar-64-363.exe.

    actually, it RealTemp 2.70 is suppose to run on an AMD processor, or at least they use to claim it would.

    the actual download is on my D: drive

    the file I click is on the desktop.

    please keep talking I am listening. and since possibly it is me not knowing what I am doing, I went to the D: drive and right clicked the file and I get the same thing I get on the desktop. now u understand what I am actually clicking on is a short cut in any fashion. all I have ever done to run it is click the rar file on the desktop and it runs after clicking the file inside which is what does not click in Win 7. and has no compatibility tab and the Run as Administrator.
  18. Zilpha

    Zilpha TS Enthusiast Posts: 319


    Sorry it took me a couple days to come back to this, but at this point I think that your problem stems from trying to run the file from within an archive file. I expect that you might have to extract those files from the .zip archive to a location of your choice before trying to run the program. While the file is still in the archive, you will not get any of the options to run as admin.

    It's really hard to understand what exactly you are doing and this is my best interpretation of what you have stated. Some screen shots would go a long way in helping us to help you.

    I didn't have an issue running the program on my copy of Windows 7 (well, except that it didn't like my CPU) so I don't think that it's a compatibility issue. I think it's related to the way you are attempting to run the file.


  19. nickc

    nickc TechSpot Paladin Topic Starter Posts: 923   +11

    Zilpha, I am not going to do any explaining I tried everything I could think of but the one thing that does work is I downloaded the new version Real Temp 3.40 and it does work. I like 2.70 better, but could never get the it to work so I will be satisfied with 3.40

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...