Windows 7 BSOD, pfn_list_corrupt

By veryconfused ยท 11 replies
Jan 7, 2013
Post New Reply
  1. I've been having this issue on my laptop for the last 10~ days. Out of the blue, my computer will bluescreen into PFN_LIST_CORRUPT, dump files, and then turn itself off. I contacted MSI Support two days ago and was told to do a factory reset. I did a factory reset, and the problem appeared fixed, but just resurfaced. I'm thinking it could be something in the dozens of Windows Updates that were installed last night, potentially a driver issue, but I'm not sure. If someone could help me interpret this, I'd be really grateful.

    Things I Have Already Done:
    -I have run Windows Memory Diagnostic twice, it did not show any issues either time.
    -I have done a factory reset of my operating system.
    -I tried to copypaste the .dmp file to my desktop and then attach it, but this site didn't seem to allow it. Any advice on that would also be appreciated.

    Here's the text I got after the bluescreen:

    Problem signature:
    Problem Event Name:BlueScreen
    OS Version:6.1.7601.
    Locale ID:4105

    Additional information about the problem:
    OS Version:6_1_7601
    Service Pack:1_0

    Files that help describe the problem:

    Read our privacy statement online:

    If the online privacy statement is not available, please read our privacy statement offline:
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234


    The Windows memory test is not very good. Download Memtest86 version 4.20 .iso fie and burn it to a CD or DVD. Boot the computer with this disk. Run Memtest86 for at least 7 passes. No errors are allowed...
    You post menidumps by going to C:\windows\minidump. Minidump files have a .dmp extension. Select all the .dmp files and right-click sending the files to a compressed(zipped)folder. Upload that folder as a file here
  3. veryconfused

    veryconfused TS Rookie Topic Starter

    Here's the minidump. I'll need to burn the disk to use Memtest86, but I should be able to do that tomorrow. Thanks.

    Attached Files:

  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The minidump shows what we already know:

    Could be a hard drive issue too. What antivirus program are you running?
  5. veryconfused

    veryconfused TS Rookie Topic Starter

    Before the hardware reset, I ran Avira. After the reset, I'm running Microsoft Security Essentials. I'm literally just in the process of running memtest, I'll report back when it's done.
  6. veryconfused

    veryconfused TS Rookie Topic Starter

    Okay, the version of memtest (4.20 .iso) that I thought would work, didn't work. When I went into the boot menu and selected the PIONEER drive, the BIOS paused, then offered me the standard choice between Windows 7 and Ubuntu. I checked, and the BIOS prioritizes disks. I assume this means the disk I burned was not, in fact, bootable.
    Is there a specific way to burn a bootable disk, or will an empty disk with a single .iso file work just as well? My Google searches on this issues have proven somewhat ineffective (although I did try using the Nero demo, which didn't let me burn any ISOs because (apparently) no disks of size <600MB were found...)
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    If properly burned, Memtest86 version disk will be bootable. Windows 7 has a built-in ability to burn .iso files. Remove Nero, it will only confuse things even more
  8. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    The EVENT VIEWER will contain ERRORS - - look for DISK errors
    Boot into SAFE MODE to reduce processes and cpu usage *may* give you more time to investigate.
  9. veryconfused

    veryconfused TS Rookie Topic Starter

    A different bluescreen message just appeared, perhaps it can help pin down the specific issue. Attached are all three minidumps that have occurred on the fresh install.
    Memtest hasn't turned up any errors yet, but it had only run for a few minutes. I'm running it again, and updates will be given as errors occur.

    Attached Files:

  10. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Still looks like a memory issue, and because it is a fresh OS install that kind of rules out a hard drive issue. After Memtest86 runs for at least 7 passes with no errors, we might look at the bios settings
  11. veryconfused

    veryconfused TS Rookie Topic Starter

    Memtest has not yet completed the first pass, but has already detected two memory errors. It does appear to be a hardware issue. Is now the time to send it in for hardware repairs, or are there further diagnostics to be done?
    I'll leave memtest running overnight, and see what other errors are revealed in the morning.
  12. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Any errors in memtest86 are not good. You can try testing each module separately to find out which one is bad and replace the bad memory module. No additional troubleshooting is necessary

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...