windows update does not detect my os - firewall to blame?

By conradguerrero ยท 6 replies
Dec 14, 2002
  1. I have usedwindows update regularly to check for microsoft product updates. After I updated my firewall, the windows update web site does not detect my system, it says, "you must be using a windows operating system to access this page"

    So I think it's my updated firewall, I closed all programs except for systray and explorer, then logged on to the internet ... the browser takes a long time to connect and when it finally does I can't load any web site.

    the firewall is:
    Sygate Personal Firewall Pro 5.0 build 1150s
    and I'm running windows 98 se.
  2. Vehementi

    Vehementi TechSpot Paladin Posts: 2,704

    If your firewall blocks ports, then it definitely would be the problem.

    Just disable your firewall and run Windows Update.

    My ISP blocks every port except HTTP, FTP, 7000 and 14000, and I can't run instant messaging, Windows Update, multiplayer games, or anything of that sort...except IRC via 7000 :D
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    It may also be that your firewall is "protecting" you from malicious ActiveX, JavaScript, Java, etc...

    I bet you can change that in the firewall's configuration.
  4. kitty500cat

    kitty500cat TS Evangelist Posts: 2,154   +6

    Norton's firewall used to disable Windows Update. I created an exception for that, and now I'm using Kerio for a firewall.

    EDIT: never mind. I didn't realize this post is 5 years old.
  5. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Nice bump kitty500cat. ;)

    Regards Howard :)
  6. Ch.

    Ch. TS Rookie

    Hi kitty500cat,

    could you maybe still tell me how that setting looked like? :)

    Thanks in advance!

    Kind regards,

  7. kitty500cat

    kitty500cat TS Evangelist Posts: 2,154   +6

    I'm not actually sure how to create an exception, since I'm no longer using Norton. What I suggest is either to disable Norton when trying to update, or simply disable Norton's firewall permanently and use another, like either the ZoneAlarm or Sunbelt firewall.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...