X850 shows black screen on boot after mains power disconnected

By yukka
Jun 3, 2007
  1. I have this strange problem that will force me to can my AGP X850PE if i cant get it fixed.

    This is not a unique occurance but i didnt make the link until this morning.

    The problem i was experiencing would be that if i changed the hardware in my pc, when i turned it back on again it would show the boot screens, then the windows xp loading bar, then the prettier windows xp loading screen (black background with the colored logo) then the screen goes blank. In a good boot it would take a few seconds then my mouse pointer appears and windows loads, but in this case the screen actually goes darker, as if all power is no longer sent to the screen but my monitor doesnt state "no signal". Thats as far as anything gets - i can hear windows xp load in the background but i cant be sure that it gets all the way to end. The only choice is a hard reset which sends me to the safe mode menu after.

    Today i accidently overloaded a plug socket elsewhere in my house (not a regular occurence) and when i came to turn my pc on, it did the same thing. From this I think that the problem isnt me removing or changing hardware, but my removing of the power cable from the back of the pc. Its causing some sort of problem with the card settings that arent fixed easily.

    The way ive fixed it previously would be to reboot in vga mode. The ati Catalyst Control Centre then tells me i have the wrong driver for the CCC but thats probably cos its loading in vga mode using the windows driver.

    I can then change driver but i cant just remove and reinstall the same driver. I used the newest catalyst drivers this time and reinstalling them doesnt sort it out. Installing newer or older or specifically "not used since last windows reinstall" does the trick but i cant be doing this permanently.

    The ati 9600pro i have does not have this problem when i remove power. My bios battery cant be to blame as my clock doesnt lose time. Im at a loss and cant find anything else on the internet that refers to the same problem.

    Maybe its just borked :)

    any ideas guys?
  2. yukka

    yukka TechSpot Paladin Topic Starter Posts: 861   +67

    i fixed it this time by disabling the ati avstream in the hardware manager.

    any clear ideas would be appreciated.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...