XP BSOD with Nero (minidump)

By MinMinLite ยท 5 replies
Nov 18, 2005
  1. Hope someone can help me with yet another DRIVER_IRQL_NOT_LESS_OR_EQUAL problem.

    Earlier this year I installed XP Pro on my D: drive, so I now have a dual boot system with 98. I've been testing XP now and then and using it for processing video files and storing over 4GB files on an external USB NTFS drive, but still use 98 for most other things such as gaming, internet, etc.

    A couple of days ago I went to burn a DVD video in XP and got this error. It used to work ok, but it's been a while since I did any burning in XP so I have no idea what's changed since then.

    I don't believe the problem is hardware-related, as I can burn in 98 with no problems. But using the same type of blank DVD's with the same version of Nero ( Ultra) in XP results in this error occurring after about 15%.

    I discovered it was using the Nero ASPI, so I got rid of it and installed ASPI 4.71, but got the same problem.

    I've also forced XP to use the same IRQ's as 98 by selecting PIC and non-plug-and-play in the BIOS as suggested elsewhere, but again to no avail.

    The BSOD does not mention any drivers, so I don't know where to look next. The last message was *** STOP: 0x0000000a (0x80AB2EFC, 0x00000002, 0x00000001, 0x804E2EED)

    Event Viewer does not report anything corresponding to the times of these crashes.

    The only other option I can think of is to do a reinstall/repair, but I'm hoping someone here can give me an alternative before I try this as a last resort.

    I've attached my last 5 minidumps. Hopefully someone here will be able to interpret them, as I've got no idea.

    Attached Files:

  2. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    The culprit is faulty ram. One minidump is crashed with memory corruption and the rest of minidumps are crashed with faulty memory.

    .trap fffffffff8960bdc
    ErrCode = 00000002
    eax=00000002 ebx=81051000 ecx=0001ebd2 edx=81051000 esi=811b2898 edi=0000ebb1
    eip=804e2eed esp=f8960c50 ebp=f8960c5c iopl=0 nv up ei pl zr na po nc
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010246
    804e2eed ff0dfc2eab80 dec dword ptr [80ab2efc] ds:0023:80ab2efc=????????
    Resetting default scope

    f8960c5c 804e959b 00010000 0000000e 814d6ad0 nt!MiUnlinkPageFromList+0xf1
    f8960c80 804fe34e de241000 00000000 80548c98 nt!MmCheckCachedPageState+0xd0
    f8960d2c 804eab2e 823ce228 8054f7e0 823cd8f8 nt!CcPerformReadAhead+0x1fd
    f8960d74 804e0f89 823ce228 00000000 823cd8f8 nt!CcWorkerThread+0x147
    f8960dac 805609b0 823ce228 00000000 00000000 nt!ExpWorkerThread+0xfe
    f8960ddc 804e8c54 804e0eb6 00000000 00000000 nt!PspSystemThreadStartup+0x34
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16

    CHKIMG_EXTENSION: !chkimg -lo 50 -d !nt
    !chkimg -lo 50 -d !nt
    804e2ef0-804e2ef1 2 bytes - nt!MiUnlinkPageFromList+f4

    [ d1 54:2e ab ]
    2 errors : !nt (804e2ef0-804e2ef1)

    MODULE_NAME: memory_corruption
    IMAGE_NAME: memory_corruption
    FOLLOWUP_NAME: memory_corruption
    STACK_COMMAND: .trap fffffffff8960bdc ; kb
    Followup: memory_corruption

    The culprit is faulty memory. You can run memtest to stress the ram. If memtest reports the ram is faulty, ram is bad. However Memtest is not a perfect tool to test the memory as some faulty ram can pass memtest.

    1. Check the temperature of the CPU and make sure that it is not overheat (ie temperature < 60C)
    Make sure that the CPU fan works properly
    2. Reseat the memory stick to another memory slot. Reseat video card as well.
    3. Downclock the ram. Check to default setting if you video card is overclocked.
    4. Clean the dust inside the computer case
    5. Make sure that the ram is compatible to the motherboard
    6. Check the bios setting about memory timing and make sure that it is on
    For example : DIMM1 and DIMM2 do not have the same timing.
    DIMM1: Corsair CMX512-3200C2 512 MB PC3200 DDR SDRAM (2.5-3-3-8 @ 200 MHz) (2.0-3-3-7 @ 166 MHz)
    DIMM2: Corsair CMX512-3200C2 512 MB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz)
    DIMM3: Corsair CMX512-3200C2 512 MB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz)
    7. Make sure that your PSU have adequate power to drive all the hardware including USB devices

    If it still crashes, diagnostic which memory stick is faulty
    1. Take out one memory stick. If windows does not crash, the removed memory stick is faulty.
    2. If you have only one memory stick, replace the ram
  3. MinMinLite

    MinMinLite TS Rookie Topic Starter

    Thanks for your help! Yes, I was beginning to suspect the RAM after reading a few other posts, but originally I thought the RAM must be ok because burning in 98 worked fine. Then I started thinking that maybe some of the 98 crashes I get are due to RAM rather than 98 instability issues....

    I ran memtest86 overnight, and 8 hours later I had one error. Then I discovered memtest for windows and when I ran that I got some "Error found with word pair# ........ or ........ (either could be the source)" messages in both XP and 98.

    So I put my RAM (one stick 512 ddr) in another slot, but I'm still getting these messages. So I guess that confirms the faulty RAM....?

    I still don't know why burning in 98 works but XP doesn't. Maybe they utilise RAM differently...? Actually, I noticed when burning in 98 that the "Buffer Level" suddenly dropped to almost zero a couple of times and then bounced back up to high 90's as per normal. Could this have been Nero accessing the faulty RAM, but 98 was able to recover from it better than XP could?
  4. nickc

    nickc TechSpot Paladin Posts: 923   +11

    98 use's less ram to run on than XP. of course it is less efficiant and will do less too.
  5. MinMinLite

    MinMinLite TS Rookie Topic Starter

    Well, I bought 512 Kingston RAM and tried it out in a couple of slots, but I'm still getting the same errors when using Windows memtest. But burning in XP now works fine! So I'm thinking maybe it's a motherboard problem...?

    So while I'm thinking this way, could a faulty m/b cause overheating on a graphics card? I'm sure my 9800Pro shouldn't be running as hot as it is, especially as it's only got a P4 2.4 pushing it, so maybe the m/b is also the problem here.... Or am I way off the mark?
  6. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    The faulty memory maybe the L2 cache memory of the CPU or the motherboard. Hardware problem it is hard to diagnostic as you don't have the tools to test the CPU and motherboard. Try downclock the ram. Maybe it can resolve the problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...