1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

XP Pro fails to copy install files during rebuild

By Hexlar ยท 12 replies
Sep 4, 2007
  1. I've been researching and googling this problem for the most part of the day, and so far everything I have found has been ruled out.


    HP nx9420 (laptop)

    XP Pro OS
    T2500 Duo Core Centrino
    1.5 GB RAM (single corsair gig stick, single factory 512)
    Hitachi 80gb 5400rpm H/D
    Radeon X1600 video chip
    System is 14 months old... and out of warranty *sigh*

    Everything about this laptop is factory besides the added gig stick of corsair RAM.


    Starting roughly a week ago, I started getting errors while playing WoW (World of Warcraft, FYI). The errors were directly related to WoW file corruption and after troubleshooting and using a tool from Blizzard to detect the problem, I found out that I needed to reinstall WoW. I dreaded the all the nightmares of doing this (fellow WoWers know what I'm talking about) I put it off....

    A couple of days later, the WoW errors turned into blue screen of death errors telling me the system was shut down to prevent hardware damage.

    By Friday night, the I got another blue screen error and upon reboot I got your typcial error message stating a windows file was missing/corrupt and the system would not boot.

    I started to rebuild the system and formatted the drive from the get-go. Everything went fine until XP started copying files to my drive. It would get to about 50% and then missing files would start popping up telling me the particular file could not be copied. At this point I have the option to skip or abort. If I chose to skip the file, I would have to skip even more afterwards and then it would not load windows. The files that won't copy are typically .dll's and such. They also appear to be random.

    My first thought at this point is that the H/D was bad. So, today when I went back to work I swapped in a new hard drive from a similar laptop. Before doing anything, I booted my system and logged in and everything seemed to work ok. At this point I thought I definitely found the problem so continued to reformat/reinstall my own copy of XP. The plot thickens...

    I started the rebuild process only to find that windows tells me it can't see my hard drive. However, I could get to the drive from the recovery console. I could even browse all my files and even the Windows CD.

    Here's a kicker... I can even get Ubuntu installed on the system without any hassle (which is how I'm online now).

    I even tried going back and installing XP pro after installing Ubuntu, but no luck.

    Other things I've tried
    - Reseating/removing my Gig stick (didn't get to the factory one behind the keyboard yet though)

    - Turning OFF the DMA/data speed option in the BIOS

    - chckdsk /p /r commands on BOTH hard drives (original & replacement)

    - Deleted/re-created all partitions on the H/D (both original & replacement)

    - Different Windows XP CD's

    - Along with several other things I know I'm probably forgetting in my frustration...

    Anyone have any idea what this could possibly be? I don't think it's the P/S but I could be wrong... the only other thing I could think of is the Mobo but I don't understand why I don't have any problems in Ubuntu...

    Thanks in advance, and sorry for the lengthy post but I know how important it is to have all the info you can when trying to diagnose a problem.
  2. Hexlar

    Hexlar TS Rookie Topic Starter

    I don't remember exactly... there was only 2 that I got this entire time. here's what I remember though..

    1) Referred to a particular process

    2) Referred to a particular windows file, haulted further progress and shut the system down to prevent hardware damage
  3. Hexlar

    Hexlar TS Rookie Topic Starter

    Here's one of the messages I got again... this time I wrote it down :)

    STOP: C000021A {Fatal System Error}
    The Windows Login Process system processes terminated unexpectedly with a status of 0x00000135 (0x00000000 0x00000000)
    The system has been shut down.
  4. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    And the problem is, drum roll please, your hard drive is failing!

    Well probably failing is my best guess. Not all of your hard drive is bad but some parts that Windows uses are failing. I actually have a drive that will format up till 49% of the drive is done and then it stops. I have used about half the drive for a couple of hours with just an error or two from the drive.

    You probably need to replace your drive! If you use this program and test your drive I'll bet you find that your drive is bad.

    If it's not your hard drive then it's your motherboard if it's not your motherboard then it's nothing. It's not your processor and everything else is your hard drive or your motherboard. Because factory clocked and voltaged processor's don't usually fail in fourteen months. I've never heard of a processor failing that wasn't overclocked or poorly cooled.
  5. Hexlar

    Hexlar TS Rookie Topic Starter

    Thanks for the reply, but as I've stated in my OP I've already replaced the hard drive and I get the same problems.
  6. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    Crap I didn't read your entire post, but I did edit my first post before I saw the post in which you rebuff me. So now you know that it has to be your motherboard. Are their other parts in your laptop I don't know about?
  7. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    For my tuppennyworth this is RAM and the new corsair stick is the culprit. Whether this is still the cause of the drive not being visible is unclear but I bet this is what started it all going pear-shaped.
  8. Hexlar

    Hexlar TS Rookie Topic Starter

    Nope, no other parts... just typical laptop hardware.

    I'm beginning to suspect the same. However, the stick isn't new... I purchased the corsair stick about a week after getting the laptop, so both the laptop and the corsair stick are 14 months old.

    I'm running a different memory test on the laptop now, Memtest86+ which I didn't realize was installed on the system when I put Ubuntu on it last night. It's pulling tons of errors. I don't think it's the corsair stick because I've pulled it out and get the same problems, so if it's a RAM issue I'm figuring it has to be either the sockets or the factory stick of RAM which I believe should be under the keyboard. I'm trying to find a manual on the laptop now to figure out how to get this thing apart to get underneath the keyboard.

    My experience with cracking open laptops is very limited. I've only accessed the factory RAM on another model laptop we have here at the firm (the nx6110 series) and they're very easy to get to because the keyboard can be removed without actually opening the case.

    I'll post a follow-up as soon as I can figure this out and give it a shot.

  9. Hexlar

    Hexlar TS Rookie Topic Starter

    Also, the biggest thing that's aggrivating the crap out of me is the fact that I can run Ubuntu on the hard drive without any problems... so I just don't get how it can be a hardware problem that isn't effecting the computer running Ubuntu.

    ARgh, I'm so frustrated I just want to say forget it and learn to love Linux, but I'm a big gamer and from my experience and from what I've read gaming isn't so easy on Linux... especially when I can't even figure out how to get my video drivers, much less other drivers, loaded.
  10. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12


    It could be the memory but I'm not feeling memory!

    It's probably a Windows device driver that causing some failing part on the motherboard to well, abruptly fail.

    Your used motherboard awaits.

    Or you can stick with Ubuntu! There is a huge community of Ubuntu users who would be happy to help you get your laptop up and running.
  11. Hexlar

    Hexlar TS Rookie Topic Starter


    I got to the factory installed 512mb stick of RAM and removed/replaced with the Corsair stick from the expansion slot. I ran another test and it picked up errors again so this time I removed both sticks of RAM and threw in another 512 stick from another laptop I have here (one that is working 100%) and ran another test... this time no errors (HOORAY...right? Wrong...)

    Now with fully functioning RAM, I try to install XP again and this time when I go to get to the recovery console to format I get an error telling me my hard drive can't be detected. ARL:KJSDFG:LJKGH!!!!!!!!!!!

    So I'm rebooting again now and going to try to get to the recovery console. I don't have much hope...


    At this point I'm def starting to feel the mobo is the issue like you Cinders :(
  12. steelfatboy

    steelfatboy TS Rookie Posts: 18

    Just curious, is the battery in place while trying to install XP? It's a longshot but it could be a faulty battery causing your issues.
  13. Hexlar

    Hexlar TS Rookie Topic Starter

    Yup, the battery is in but I also have the charger plugged in.
    I'm running the BIOS HDD test again and once it finishes I'll try pulling the battery out and doing the install. Thanks for the idea.

    Tried the battery idea, and no luck....

    New RAM, new hard drive, and now it won't detect any hard drive I install. The XP CD loads and then I get an error saying the hard drive can't be detected and I'm forced to just F3(Reboot). This is only the 2nd time in my 8+ years using Windows computers that I have been beaten and I'm not liking it very much :(

    I guess I'm going to have to wait until I can get up enough funds for another motherboard.

    Thanks everyone
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...