Download Instructions:

This installer has built-in support for English, French, German, Spanish, Italian, Danish, Dutch, Swedish, Finnish, Portuguese, Norwegian, Polish and Russian.

System Requirements:

* Macintosh OS X 10.3 - 10.6 (includes PPC and Intel) Learn more.