1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Canon Pixma MP750 scanner problem

By Gouge · 11 replies
Jul 18, 2012
Post New Reply
  1. I have owned a Canon Pixma Mp750 Muli-functional printer for several years and it has always worked perfectly on my Windows XP PC.

    I have purchased a new Windows 7 PC and updated the printer and scanner drivers from the Canon download website. The printer works great, but the scanner won't scan.

    I've tried using the MP Navigator, Scangear and the Windows Scan & Fax facility but the process only gets as far as the calibration stage and stops. I eventually get an error code 2,178,0. I have tried to resolve it by changing the USB port, uninstalling the drivers and re-installing them, but the scanner still won't scan.

    Any ideas, guys? The Canon support team appear to think it is a Windows error, but I'm not so sure. The drivers all seem to be installed correctly.
  2. shrutisharma

    shrutisharma TS Rookie

    I have canon pixma e500. using windows xp 64 bit. the scanner and copy functions are fine but no print. if I connect it with windows 7, everything works super fine.
  3. jobeard

    jobeard TS Ambassador Posts: 12,486   +1,428

    Instead, use the MP Navigator and just click Photos/Documents (platen) which will use the Canon
    software directly w/o the Windows drivers - - it works on my Win/7 Pro
  4. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    Hi, I had a few problems with an HP Scanjet scanner, and found that the program Faststone image viewer has a scan option, which did make the installed HP software work. In that editor, File, Aquire images from scanner.
    Might be a trick that would work with other scanners.
    Also I found the software needed to be 'Run as administrator'.
  5. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    No it doesn't work.

    I have Windows 7 Home Premium (64-bit). MP Navigator download - mpnwin106eal13.exe.

    When I try using navigator, after about a minute I get the error message

    Cannot scan for these reasons:
    - The original may not be set correclty
    - The Protection Shield may be put in place
    - The lamp may not be warmed up

    Scanner drivers will be closed

    Code: 2,178,0

    If I connect my WinXP laptop to the printer it scans and prints perfectly.

    So I suspect the drivers are at fault. Tried to fully uninstall and re-install all Canon drivers, but scanner still fails.
  6. jobeard

    jobeard TS Ambassador Posts: 12,486   +1,428

    my navigator (Win/7/Pro 64bit) is located at
    \Program Files (x86)\Canon\MP Navigator EX 1.0\mpnex10.exe

    try setting the compatibility to XP SP3 on the properties
  7. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    Ah, there could be the problem. My file is MPNavigator1.0\mpn10.exe.

    I'm sure that the file I downloaded was for NavigatorEX!!.

    I'll look again, but if you have a definite link, I'd appreciate it.

  8. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    Problem still exists.
    There appears to be no MP Navigator EX software for the PIXMA MP750. The latest version for W7 in the UK/Europe is apparently 1.0. I'm sure that it is the same as I had for XP.

    I tried to install the one that you use Jobeard, but the drivers were not compatible.

    I've changed compatibility for all application files to XP SP3 but it still doesn't work.
  9. Gouge

    Gouge TS Enthusiast Topic Starter Posts: 128

    I’ve solved the problem!! Having completely uninstalled all Canon software with Revo Uninstaller and then manually deleting anything else, I re-downloaded and installed all drivers etc. Still didn’t work.

    I went into the Printer section of Control Panel and tried to get info on the scanner drivers, but got an error message 0x00000015. It was a WIA problem!!

    What I did was to follow this procedure (from Microsoft Answers: http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/operation-could-not-be-completed-error-0x00000015/68244f52-b556-4b83-a9c9-926dc9098ae7)

    1. Click on start or the Window thingy (sic).
    2. Type Services or Services.msc in the search part.
    3. Now scroll to the following services in the window that got opened.

    Remote Procedure Call (RPC)
    DCOM Server Process Launcher
    RPC Endpoint Mapper
    Shell Hardware Detection

    Enable those services. To do so right click on them, click properties and make it automatic. Once you enable all of them start them. After all the services are started scroll for "Windows Image Acquisition" make this automatic too and start it. Just reboot your PC and you should be good to roll.

    I found that Shell Hardware Detection was disabled, so I made it automatic. Then started Windows Image Acquisition.

    I re-booted and the scanner now works!!! J

    You can now close this thread as resolved.
  10. jobeard

    jobeard TS Ambassador Posts: 12,486   +1,428

    GREAT :) Thanks for showing your solution for others that may follow!
  11. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    Hi Gouge, Thanks for the good info, had a similar problem with a HP Scanjet 2710, never really solved it.
    Have copied your solution to use in the future if this happens again.
  12. member: 199763 is a genius//thank you for solving a very perplexing problem//Victor

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...