"Error loading OS" on clean install

By Mike2 ยท 22 replies
Dec 21, 2007
  1. In an nutshell: Put an old (working fine) WG 120G IDE HD into a new system, did a clean XP Pro install, booted up fine a few times (when I left the XP Pro CD in the CD Drive), but when I took the XP Pro CD out of the CD Drive, it halted after the BIOS screens with "Error loading OS" (right after the "Verifying DMI Pool Data" message).

    If I put the CD in the CD Drive, and let it boot up *from the HD* (touch no keys when it says touch any key to boot from CD), then it apparently boots up from the HD just fine. Comes up all the way to the windows desktop, obviously loading the Windows configuration from the HD.

    If I take the XP Pro CD out of the CD drive, it halts with the "Error loading OS" message.

    I've used Recovery Console with fixboot and fixmbr, same results. I've tried several IDE cable swapouts, same results. Checked master/slave jumpers, tried cable select and dedicated master/slave configurations, same results.

    Background: Just built a new system with a Gigabyte N650SLI-DS4L Mobo, 4G RAM, booting from the IDE 120G WG HD. Also has a SATA Maxtor 500G HD for data, on the SATA IF on the Mobo. The only other anomaly is that it has a Maxtor SATA/150 (w/ IDE) PCI card to drive a second IDE CD-R drive, but when it boots up to load that add-in card into the BIOS, it says "no device found" so it doesn't load the card drivers. However, with that card installed or pulled out, it has the same results (same "Error loading OS" message *only* when Win XP Pro CD is not in the CD drive). So that card is apparently not relevant to this problem.

    Is it really booting from the CD even though I don't "touch any key"?
    Any suggestions on what to do next to troubleshoot this?

    Thanks in advance for any suggestions!
    -=- Mike
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    The HD is taking too long to spin up and the BIOS tries to load the bootloader before the drive is ready. Trying to boot from the CD inserts a delay long enough so that the HD can respond.

    See if you have a "HDD delay" or similarly-named option in the BIOS. Put 5 or 10 seconds there. Another option would be to disable "quick boot" or enable memory tests to make the POST take longer and give the drive some time to get up to speed.
  3. Mike2

    Mike2 TS Rookie Topic Starter

    Wow, that sounds like a really great theory, Nodsu. I like it.

    But I've just spent an hour going through the BIOS settings, and I can't find one for HD Delay, quick boot or memory tests. Very frustrating, because I've seen those in other BIOSes. It's an Award BIOS v6.00PG. I have the same BIOS on *almost* the same motherboard from Gigabyte (one version earlier), with *almost* the same WD HDD (80G instead of 120G) on a "sister" system with no bootup problem. I've gone through both BIOSes, doing a line-by-line compare, and can find no significant differences except where I expect to (newer board has 1 IDE channel, not two, etc).

    Way back in the old days of win.ini and config.sys, you used to be able to pause the POST screen with Ctrl-S. Can't do that anymore. Besides wanting to read more of the POST screen that I can't see, I was thinking that inserting a manual pause like that would provide evidence to support the "HD spinup time" theory. Are there any other ways to slow down the POST?

    The attempt to load the BIOS for the SATA/IDE PCI card already inserts a fair delay. About 7 seconds, I think. And still I get the "Error Loading OS" boot failure.

    Thanks again for the help,
    -=- Mike
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Ctrl+S? That's rare. Use the Pause/SysRq key for pausing POST.

    If you have a reset button, then you can use that too to test the theory. Start up the computer and let it run until the error message. Then press reset. The HD will not spin down and the second boot will be with a drive that is completely online.
  5. Mike2

    Mike2 TS Rookie Topic Starter

    Did that several times. Each time it comes up with the "error loading OS" halt. Darn, I really liked that theory.

    When I tried the fixboot and fixmbr fixes from the Recovery console, each time I got a message that it was successful. I suppose it's possible that there is some disk flaw that is corrupting the boot sector repeatedly. I wonder if, when fixboot writes to the hard drive, if it verifies what it wrote? Probably not.

    I'm trying to think of some other approach besides getting another hard drive. Since this one has worked fine for a long time, I trust it. My priority is figuring out if there's something wrong with the motherboard, because if it's a bum motherboard, I need to send it back (bought it a few weeks ago). Any thoughts on ways to check out the motherboard/chipset?

    I'm sort of at a loss right now. Thanks for helping, Nodsu.

    -=- Mike
  6. Rik

    Rik Banned Posts: 3,814

    What happens if you change your boot order to hdd first?
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You could have a MBR that Windows doesn't like, yes.

    A surgical strike would be zeroing out the boot sectors, recreating the partition table and doing fixmbr/fixboot. A more robust approach is wiping clean the entire beginning of the drive and reinstalling Windows.
  8. Mike2

    Mike2 TS Rookie Topic Starter

    Sorry, guys I had to disappear for a week for a Christmas family visiting trip.

    Rik: Changed the boot order as you suggested. Results are almost the same. With no CD in the drive, it boots to the "Error loading OS" halt. With the CD in the drive, it *also* boots to the "Error loading OS" halt. Previously with the CD in the drive it would boot to the Windows installation on the HD, but with the CD *after* the HD in boot order, it never sees the CD.

    Nodsu: I don't know how to zero out the boot sectors and recreate the partition table... I suppose I would use a utility like Partition Magic or something? But I have already booted to the Recovery Console, exectued both fixboot and fixmbr, and they reported success at writing new boot sector and MBR.

    I think I'll just try the Windows reformat/reinstall next, although I did that just before this "clean install", so it doesn't give me much confidence that I'm not just getting into the same mess again. It will be difficult to trust this 120G HD if I can't explain what happened. It's a big investment in time to install all my programs again, so if I've got a bad HD, I don't want to waste time on this HD. However, this HD has been booting flawlessly for years in my other system.

    Part of my confusion is just that I don't understand the process for why it would be booting off the CD when I tell it not to, and then loading the OS from the HD. Yet it won't boot off the HD.

    Also another little question: Sometimes when I boot up, it offers the option to run recovery console, but sometimes it doesn't. For some time I wanted to run recovery console, but I just had to keep rebooting until it finally gave me that option. Anyone have some hints on that?

    Thanks, -=- Mike
  9. captaincranky

    captaincranky TechSpot Addict Posts: 13,036   +2,558

    This May Help, Or Maybe Not....

    To rid oneself of stubborn MBR sectors and what not on a drive, I would put it to the drive with a drive scrubber utility such as; "Iolo Drive Scrubber 3". This type of utility returns the drive to the day it came out of the box brand new. This is a paid program normally. I don't know of another freeware program of the same type.
    If the drive isn't spinning up fast enough, is the drive working properly? Isn't simply placing the optical drives first in the boot order usually enough of a delay? I had thought that the BIOS delay would be more appropriate for USB and/or keyboard detection.
  10. Mike2

    Mike2 TS Rookie Topic Starter

    Thanks, Captancranky... but earlier in the thread we concluded it wasn't the HD spinning up delay, because that wouldn't be a problem with reset button restarts, and besides, there's already a long delay for the BIOS add-in for a SATA/IDE board.

    OK, to explain my next phase of troubleshooting I need to give a little more background for you experts.

    Four months ago I build a system (SYSTEM A) with:
    Motherboard - Gigabyte N650SLI-DS4 (no L) (Two IDE channels)
    Boot HD - WD 80GB (WD800JB)
    It's been working fine for four months, booting up (with no CD in the drives)

    This month (Dec) I tried to build an identical system (SYSTEM B):
    Motherboard - Gigabyte N650SLI-DS4L (note only one IDE channel)
    Boot HD - WG 120GB (WD1200JB)
    The slightly earlier version of the motherboard (without the L) was no longer available - discontinued for this slightly "improved" version.

    My original problem I described here was that SYSTEM B (*ONLY*) would:
    - Boot up to "Error loading OS" in a normal configuration
    - Boot up to the Windows installation on the HD *only* if there's a bootable CD in the CD-drive

    So, to troubleshoot this, I swapped the HDs between the two systems.

    When I moved the WD800JB (80G) HD from System A to System B (to the system with the problem) the same problem continued exactly the same way in System B. So, I'm thinking, Aha! It's the DS4L motherboard!

    But I also moved the WD1200JB from System B to System A (to the system that was having NO problem), and the SAME PROBLEM recurred! Boots to "Error loading HD" unless a bootable CD is in the drive, then it loads Windows from the HD!

    Totally befuddled, I restored the HDs to their original location. Now *both* systems (in their original configuration) have the problem! Arrgh!

    New theory: The new DSL4 motherboard not only messes up drives during windows install (MBR or something?) it also messes up drives with a good windows install that are installed on the system? So maybe if I do fixboot and fixmbr in System A, that will fix the problem on the WD800JB?

    But I can't get Recovery console to start. When I boot to the CD, I get "Setup is examining your hardware" and then it leads me to reinstalling Windows on drive C with no option for Recovery console. So my immediate question is how to get to recovery console again. (I asked that question earlier).

    And my ultimate question is... what the hell is going on with my systems?

    Any help is greatly appreciated. -=- Mike
  11. Mike2

    Mike2 TS Rookie Topic Starter

    Correction: Earlier post I said DSL4 when I should have said DS4L.

    Update: I installed Recovery Console on the hard drive (w/ tip from the Microsoft site) so I can access it by booting up in my usual unusual way (Boot CD then load Windows from the HD).

    I ran fixboot and fixmbr, but that didn't help the problem.

    One strange thing I noticed... The first time I ran fixmbr it started by saying:
    "This computer appears to have a non-standard or invalid master boot record", then the usual warnings about "are you sure you want to do this". Afterwards, it says "The new master boot record has been sucessfully written".

    If I immediately run fixmbr again, it *still* starts out by saying "This computer appears to have a non-standard or invalid master boot record". Which you would think it wouldn't say that, if it just fixed it. So I run it again, with the same results. And when I reboot, I still have the same "Error loading OS" halt, unless I have a bootable CD in the CD Drive.


    -=- Mike
  12. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Contrary to popular belief,fixmbr does not write a completely new MBR. You would lose all your partitions, wouldn't you? It only reinstalls the default Windows bootloader and leaves the partition table untouched. So if your PT is FUBAR, then it will remain like that. Fixboot installs the secondary bootloader inside your Windowspartition so that has got nothing to do with MBR. Formatting has got nothing to do with the MBR too, since this is a filesystem operation that happens inside partitions.

    As I already hinted and captaincranky said, use adisk wiping utility to zero out the drive or at least the beginning of it. DBAN is free.
  13. Mike2

    Mike2 TS Rookie Topic Starter

    OK, I hadn't heard of DBAN before, but I found it's website, and I'm thinking about doing that.

    But I would still like to understand what's going on. Can a motherboard mess up a HD's partitions or boot sector like that, just by connecting it to the IDE channel and trying to boot from it? Yet it loads the rest of the windows installation no problem? And why is it booting from the CD (when I don't "press any key") then loading Windows from the HD. Is that normal?
  14. captaincranky

    captaincranky TechSpot Addict Posts: 13,036   +2,558

    Just Silly Superstition But.......

    This is a non-technical, empirical, purely theoretical response but, if an IDE channel were transmitting incomplete, incorrect, or scrambled information to a HDD which was then writing that info....., wouldn't the GIGO rule apply? (This with respect to what would come out of the HDD).

    Trial by substitution is a formidable tool for diagnosis. However, I would apply it in a more cautious manner. Given your situation, (and remembering hindsight is always 20/20), I would have brought the HDD into "Computer A" (as a slave), and ran a disc check. If it failed this, I'd let Windows fix the error, and try again in "Computer B". Trying the drive (with data and an OS on it) from the working box into the broken machine is admirable, but perhaps a bit too brave.
  15. Mike2

    Mike2 TS Rookie Topic Starter

    Roger that on 20/20, Captaincranky. But since I could boot System B to the desktop, I had previously run CHKDSK on the originally faulty drive in System B. Since Windows was working fine, I figured CHKDSK would have found errors on the drive if there were any, but it didn't. But you're right, it would have been more cautious to also run CHKDSK on the drive after it was moved to System A as well.

    DBAN only wipes data, right? (I'm reading up on it now). Not partition or formatting?

    Would it be better to instead (or in addition) do a low-level format with the WD tools?
  16. captaincranky

    captaincranky TechSpot Addict Posts: 13,036   +2,558


    I don't know exactly what DBAN does, so I guess I'll Google that in a minute.
    "Drivescrubber 3" (Iolo) wipes EVERYTHING from the drive and returns it to an unformatted, unpartitioned state, as new, period. It will do it to a military, even NSA standard. This is so should you decide to donate the drive to an underprivileged KGB agent, or some malnourished Taliban warrior, your MP3 files won't be used to undermine the government of the United States.

    With, respect to substitution of components, I did say "hindsight is 20/20", which is a more (slightly more) poetic way of saying "if I knew then, what I know now", which is a slightly less self incriminating way of saying, "I might have panicked and did the same damned thing".

    With the 120GB HDD you have nothing to lose with a total wipe, (I don't think), since (here I'm guessing), Windows hasn't been activated. The jeopardy is with the 80GB drive since as is obvious you will lose everything. Here, I would wipe the 120 clean, install it in box "A" load Windows, then return the 80 to box "A" as a slave, try to retrieve my data, then wipe that drive. That's the best way I can think of to make a really bad day not turn into one of the worst you've ever had

    I really think this Mobo may be an RMA waiting to happen. The only other thing I can think of is that it's set to the wrong HDD mode in BIOS, but that's silly.

    "ADDENDUMB": DBAN realy doesn't seem to be the same as "Drivescrubber", this I got from reading the FAQs at the web site. It's a doomsday weapon as opposed to a tactical device. But I have to say, doomsday may be what will work best.
  17. Mike2

    Mike2 TS Rookie Topic Starter

    Started DBAN a little while ago, and it's at 00.22%, so this will take awhile. I'm using the the DoD short version, making 3 passes.

    You're right, Captaincranky, about not having anything to loose on the 120G drive, so I started it.

    I also think the MB may be an RMA case, and I've sent a preliminary note to the vendor, and told them in no uncertain terms that I expected them to come up with some answers. I bought both MBs (Systems A and B) from the same guys, pre-tested. They're closed on Sundays, though, so I won't hear back real soon. And yes, I'm sure the BIOS is trying to boot from the right HD. Periodically, I tried it with the other HD removed, same symptoms.

    Thanks for all the help, TechSpot gurus. I'll keep you posted.
  18. captaincranky

    captaincranky TechSpot Addict Posts: 13,036   +2,558

    Best of luck.....

    I hope you get this resolved soon, keep us posted.

    I may have not fully understood the FAQs on DBAN.
  19. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    I salute you well written well done Mate

    I don't like Iolo software
    low level format on modern drives is writing 1's or 0's to the drive
    once should be enough and more puts a strain on the disk

    good luck and have a happy year ahead of you all
  20. captaincranky

    captaincranky TechSpot Addict Posts: 13,036   +2,558

    Samstoned.........Many Thanks...!

    "Drivescrubber 3" is a very useful utility. It will also do a "low level format", it's menu offers this as an option. I got paid a nickel to buy it. ($29.95 USD with a $30.00 rebate)! Yeah sure, I burned a stamp and a 40 mile (round trip) to CompUSA in Delaware, tax free shopping, yeah! But, given CompUSA's current predicament I don't think they'll be running that promo again anytime soon. The rebate check was issued and in my hand within 6 weeks, if memory serves. I didn't send it to my credit card company, so, win some, lose some.
    As to their other software, I walked away wondering whether it was bloatware, vaporware, or bloated vaporware, so I left it on the shelf for CompUSA to ponder.

    Again many thanks....,much appreciated!
  21. rf6647

    rf6647 TS Maniac Posts: 829

    call me crazy

    RE: Mike2's update on troubleshooting
    I will relate my findings with "vintage" WDC HDD's. The WDC HDD needed a slave device on the same IDE. It was independent of the mobo.

    Vintage of WDC: 27GB was huge back then. Mobos: syntax (?), asus a7n8x. If I could find my notes, I would use them to claim it was WDC design problem.
  22. Mike2

    Mike2 TS Rookie Topic Starter

    Interesting idea, rf6647. After all, what's a master without a slave? Sure enough, in the original system (B) that had the problem, there is no slave.

    Big update: In our last episode, I had started DBAN on System B, with the idea of using a disk wiping utility to zero out the drive. But DBAN was going to take over 2 days, and since I expected to hear from the vendor's tech support in less than that, I didn't want the system tied up for that long. So i terminated it after a few hours, and instead used WD's utility to "write zeros" to the drive, which completed in a few hours (writing once instead of several times).

    It fixed it, apparently. I was able to install XP Pro again, and at each step I tested the bootup capability to insure I didn't get the "Error loading OS" with or without the CD in the drive.

    I'm still not exactly ecstatic, because I don't know what caused the original problem, so it's at risk of recurring at any time. I don't like it when I fix something but I don't understand why.

    The greatest mystery is why did it mess up the HD from System A when it was put in System B. Recall that the systems are almost identical, and it should have booted up fine, then that same HD had the same problem when it was put back in System A. As if it was "contaminated" by the problem in System B.

    So, I'm still very suspicious of the MB in System B, and keeping a close eye on it. My vendor's tech support will no doubt say that the problem is fixed and they have nothing more to do. Does anyone have any suggestion on what I can say to hold them to task on the origin of this problem?

    It just occurred to me... I think I need to look into a MBR backup utility, and keep a backup on hand. It would be interesting if restoring from a backup fixed it. Although I assume that fixmbr (from the recovery console) does everything an MBR backup utility would do. Is that correct?

    Meanwhile, I still have the problem with System A, but with a hard drive that I really don't want to wipe out unless necessary. I haven't found a utility that writes zeroes to the boot sector or MBR *only* and then restores it. All the "fill with zeroes" utilities that I have seen seem to do the whole drive. One thing that I did with System B after I filled it with Zeroes was to use WD's vendor utilities to "prep" the drive for booting with XP, which obviously does some stuff with the boot sector and MBR. I wonder if I can do that and still retain the data on the drive. Sounds risky.

    Thanks to all who provided insight/suggestions.
    -=- Mike
  23. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    As I already said, fixmbr writes the default bootloader to the MBR. It is nowhere near a MBR backup.

    If you want to back up or clear only the MBR, then you can use the builtin utility of every unix OS - dd. MBR consists of the first 512 bytes of a disk. The default block size of dd is also 512 bytes. So if you wanted to back up your MBR you would run something like "dd if=/dev/hda of=somefile count=1" (means: copy (512 bytes) from /dev/hda (the typical first hard disk on Linux) to somefile one times). To clear the MBR: "dd if=/dev/zero of=/dev/hda count=1" (copy (512 bytes) from a bucket of zeroes to the first hard disk and do this one times)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...