Floppy drive not able to read disk

By huck_finn
Aug 6, 2005
  1. Hi everyone,

    I just built my first machine and I'm having a problem with the floppy. It wouldn't let me use Fdisk to partition anything in the beginning, but I was able to load Windows via a disk. After install, I tried the floppy again, no luck. I used the disk with drivers that came with the mobo, still nothing. I swapped it out into another computer and the floppy works, so I'm at a loss. I've also tried 2 different ribbons. I'm wondering if a Bios update will fix it?

    Thanks for any help!!

    Gigabyte KA8N Ultra-9
    1gig Corsair DDR400
    AMD 3200+ Venice
    Sony Floppy Drive
    Zalmann 7700 CPU Fan
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Did you enable the floppy drive in BIOS? And in Windows?
    Cable mounted correct? Using the proper 'twisted' cable?
    When you talk about disk, do you mean floppy disk or CD?
    Please be as clear as possible.
  3. huck_finn

    huck_finn TS Rookie Topic Starter

    I did mean to say CD instead of disk... sorry, it was a late night last night.

    The BIOS is set to boot from the floppy first, and it's recognized in the CMOS. The connections are right, and they're in all the way.. and power is connected.

    How would you enable/disable it in Windows? And is there another spot in the BIOS I should be looking at?

    FYI: I had linux installed and it didn't recognize the floppy either.

    The light comes on, and it sounds like it's reading the card, but I get the error that there is no disk in the drive.... I've tried a few different disks. I'm getting a new SATA drive to install, and I'll need it to get the drivers installed.
  4. huck_finn

    huck_finn TS Rookie Topic Starter

    OK I got it... you, and everything else I read was correct about the ribbon not being connected properly. I was sure that I'd had it in properly because of the pin/bump whatever you call it on the end of the ribbon... it should only fit one way right? WRONG! What I never noticed was the other groove on the floppy drive. I flipped the ribbon over and it's working perfectly... how could one little issue drive a person mad for so long!!!!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...