1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Get "setup did not find any hard disk drives installed in your computer"

By dunk ยท 9 replies
Jan 19, 2007
  1. i get the message "setup did not find any hard disk drives installed in your computer" when i try to install windows xp on a dell dimension 5150c with a 160G WD SATA drive. the bios detects it fine and the diagnostics indicate that it's okay and norton ghost is able to access it. this post:


    indicates that i should try setting my sata operation to "combination". i have no such setting in my bios. i have only ahci and ata for this setting. i've tried both with identical results. do i need scsi drivers to install windows? thanks for any help.
  2. Rik

    Rik Banned Posts: 3,679

    This is one of the most common problems we see here on TechSpot!
    What you need to do is press F6 for third-party scsi or raid controller just as the Windows install is starting. You then need to insert your SATA driver disk.
    If you do not have one then you will need to go to the Dell website and download the correct one for your PC and put it on to a floppy disk.
    This should get all working.
  3. dunk

    dunk TS Rookie Topic Starter

    thanks for the reply. i've looked at the dell website for this computer model and they don't list any scsi drivers for it. i've posted a question about it on the dell forum. thanks again.
  4. Rik

    Rik Banned Posts: 3,679

    Please read my previous post properly. At no point did I say that you needed a scsi driver. I instead said that you need a SATA driver.

    You will not find a scsi driver your machine because it does not have scsi.
    You will however find a SATA driver as you machine does have SATA.

    Windows XP was written long before SATA existed. For that reason you have to add the SATA driver to it.
    These third-party scsi or Raid controller part of the installation process allows you to do this.
  5. dunk

    dunk TS Rookie Topic Starter

    i tried the scsi driver supplied by dell but i stull get the same error message from setup. so now i'm screwed.
  6. Rik

    Rik Banned Posts: 3,679

    For the third time.


  7. dunk

    dunk TS Rookie Topic Starter

    okay okay the SATA drivers! anyway, the drivers i downloaded from dell are sata drivers. they just don't work.
  8. Rik

    Rik Banned Posts: 3,679

    Tell me exactly what driver you are attempting to use, give me the link to where you got it from, and explain exactly how you attempted to use it???
  9. dunk

    dunk TS Rookie Topic Starter

    i got the driver from here:


    i put the driver on a floppy. i hit F6 when i booted off the xp home cd and when it prompted me for the floppy i inserted it and hit "s" to add an additional device. it listed the following:

    Intel(R) ICH8R/DO/DH SATA RAID Controller (Desktop ICH8R)
    Intel(R) ICH8R/DO/DH SATA AHCI Controller (Desktop ICH8R)
    Intel(R) 631xESB/632xESB SATA RAID Controller (Server/Workstation ESB2)
    Intel(R) 631xESB/632xESB SATA AHCI Controller (Server/Workstation ESB2)

    i chose "Intel(R) ICH8R/DO/DH SATA AHCI Controller (Desktop ICH8R)". i told setup to continue and it gave the same message as before: did not find any hard disk drives in the system. i also tried loading "Intel(R) 631xESB/632xESB SATA AHCI Controller (Server/Workstation ESB2)" but it told me windows already had one of these but gave me the option of loading it anyway. i tried both not loading it (presumably using the windows version) and loading it. both produced the same failure.
  10. ta3one

    ta3one TS Rookie

    I know that this thread is long dead, but it comes up as the first result on google so I would like to add my $.02

    I have dimension 5150c and SATA drivers on Dell website are the wrong ones ... you need PCI ID 8086:27C1 but the driver provided does not support device by that ID.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...