1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Having "Setup did not find any hard disk drives installed in your computer" problem

By Dominik · 8 replies
Jan 19, 2009
  1. System:
    -Microsoft Windows XP
    -Media Center Edition 2005
    -Service Pack 3
    (I initially started with an “HP Media Center m1050y” machine in 2004, but I’ve since upgraded the motherboard to one made by Foxconn as described below.)
    -Intel Pentium(R) 4 CPU
    -3.2 GHz, 1.00 GB of RAM
    -Samsung Serial ATA
    -Model: HD501LJ
    Graphics Card:
    -ATI ALL-IN-WONDER X600 PRO Series
    (If googling, just copy the following “Foxconn Socket 775 6627MA-RS2H Motherboard” or “Foxconn 6627MA-RS2H Motherboard” for best results.)
    -Foxconn N15235
    • SiS 662 + 966L
    • Socket 775
    • FSB 800/533MHz,OC to 1066MHz
    • PCIex16
    • DDR2 667/533/400
    • USB 2.0
    • 6 Channel Audio
    • 10/100M Lan
    • RAID
    • Serial ATA

    Basically, I’m having a "Setup did not find any hard disk drives installed in your computer" problem during a clean reinstall of WinXP OS. Already tried the “slipstreaming” technique as well as using a floppy disk drive via F6 during boot up, both to no avail, still get the same error message. I also tried changing the RAID settings to IDE, and although it worked thereby allowing me to install my OS, it was at the cost of significant performance loss. My system is now reaaaaaaally slow compared to what it used to be before I did the WinXP reinstall with the IDE settings. For example, if I drag an application window around my desktop, I see a choppy tail trailing slowly behind it trying to catch up to the main window. Absolutely horrendous! Same thing goes for scrolling up and down pages in my browser or in a Word document, it just has that lag before it reacts to any input.

    Here are the specifics:
    I did a clean reinstall of Windows XP Media Center Edition 2005 Service Pack 3 using the following BIOS setting (it’s the last one in the sequence in quotes)( (see link to screenshots of my BIOS below)): Standard CMOS Features > Integrated Peripherals > OnChip IDE Device > SiS Serial ATA Mode > "4P(IDE)+2S(IDE)". The other two options available to choose from this menu are, "4P(IDE)+2S(RAID)" and "4P(IDE)+2S(AHCI)". Which of the three options should I use? Shouldn’t it be the "4P(IDE)+2S(RAID)" setting for best performance since I am using a SATA drive? I heard that SATA drives set to "4P(IDE)+2S(IDE)” mode in the BIOS (my current BIOS settings) suffer a significant performance loss as a result, therefore you should stay away from that setting if dealing with SATA drives.

    I’ve already spent days and went through 4 or 5 DVD-R’s trying to “slipstream” Foxconn RAID drivers, Chipset drivers, as well as other Foxconn drivers onto the Windows XP Media Center Edition 2005 Service Pack 3 installation CD using nLite(to slipstream) and PowerISO(to burn the bootable ISO DVD-R), only to encounter the "Setup did not find any hard disk drives installed in your computer" error all over again. Like I mentioned earlier, I can bypass the error if I change the Standard CMOS Features > Integrated Peripherals > OnChip IDE Device > SiS Serial ATA Mode settings to option "4P(IDE)+2S(IDE)", which I did do. But obviously I don’t like the severe performance loss I am experiencing as a result.

    So here’s the big question! Is the "4P(IDE)+2S(IDE)" setting I am currently using fine, or should I switch it to "4P(IDE)+2S(RAID)"? If the answer is yes, then how should I deal with the “Setup didn’t find any hard disk drives etc, etc.” error? Any ideas? Did I slipstream my disks wrong? Or use the wrong drivers? Btw, I followed the slipstreaming instructions on this page, http://www.howtogeek.com/howto/wind...d-disk-drives-during-windows-xp-installation/ .

    I realize this issue has been dealt with in these forums before; the difference being they had it on a different system with different BIOS settings, plus I’m coming into this just having changed my RAID “mirror” dual hard drive setup back to a single drive setup (if that makes any difference). I also wasn’t able to resolve this issue following any of the advice given to the people who have posted before in regards to this problem. So, I figured I needed to start a new thread.

    Thanks for reading. Looking forward to your feedback and hopefully some relief.


    Downloaded the drivers I used for slipstreaming from here.
    And here:

    Link to screenshots of my computers BIOS.

    Important Note:
    Previous to my recent reinstall of the OS I had a 2 hard drive RAID setup (“mirror/RAID 1” if I remember correctly, although it might have been a "RAID 0/data striping" setup, I can't recall for certain) with a 500GB Samsung SATA drive and a 250GB Western Digital SATA drive. I know, I know! Different brands, different sizes, not the best idea in the world, but it worked for over one year for me that way. But anyways, before my reinstall I changed things back to a normal non-RAID one hard drive setup using only the 500GB Samsung drive. Could “jumper” settings be the problem here? Or not since ”jumper” settings only apply to IDE drives?
  2. vnf4ultra

    vnf4ultra TechSpot Paladin Posts: 1,388

    Just a thought but regarding:
    The above sounds like you just need to install graphics drivers. Have you checked to see if your drivers are all installed in device manager? To do so you can just click start>run>devmgmt.msc and hit enter. If any devices have exclamation points beside them, then they're missing drivers.
  3. Dominik

    Dominik TS Rookie Topic Starter

    Hey, thanks for the heads up on that vnf4ultra, you were absolutely right! The trailing tails are gone now, :). I just needed to reinstall the graphics card drivers, which I forgot to do after I reinstalled the OS. I'm happy about that, but there are still some issues that need to be resolved. For example, I still don't know if my BIOS settings are properly configured for the SATA hard drive I am currently using. Anybody get a chance to look at the BIOS screenshots I uploaded yet?

    Let me just simplify things a little bit by taking things one step at a time, as my initial post was rather lengthy and potentially confusing. Sometimes I give much more information up front than is needed and that can complicate things. Sorry about that. Let me start simply by asking which of these three Bios settings should I be using for a SATA drive?
    1.) 4P(IDE)+2S(IDE)
    2.) 4P(IDE)+2S(RAID)
    3.) 4P(IDE)+2S(AHCI)

    See screenshot of these BIOS settings here, http://viewmorepics.myspace.com/ind...dID=75594228&albumID=2645700&imageID=42626260
  4. iMoose

    iMoose TS Rookie Posts: 57

    I'm considering a SATA HDD when I replace my mobo. Hmmmmm.

    So which is the best? I wish I knew, bro. But I'm still learning all this stuff.

    I hope it works!
  5. Dominik

    Dominik TS Rookie Topic Starter

    Hey iMoose,
    You know, it does works, I just don't know if I'm getting anywhere close to the performance I could be getting out of it with my current BIOS settings. Why use only a portion of the potential of your system, right?
  6. iMoose

    iMoose TS Rookie Posts: 57

    I thought it should work, provided there was proper PSU and mobo connections.

    Er, what I really mean is: I'm so damn cheap, that I'm thinking of upgrading my LAPTOP's HDD, then using the replaced 160GB drive in my older eMachines DESKTOP by replacing the mobo (already planned!) to one that has SATA 1.5 capability, yet still uses my socket 478 Celeron D 340!!!!

    Yup, I don't really think I can be any cheaper! lol

    But it should work. And with 4GB of DDR2 on the new desktop's mobo, performance differences should be minimal, right?

    I think. I don't know. Hopefully?

    I hope! Does it sound too crazy?

    The real trick would be if I just slapped it in the desktop without re-formatting so I can just run pre-installed Vista! They're both eMachines, and both bought new by me
    (or brother who's deceased)

    THAT would be pretty neat!

    If that were so, I'd feel better about buying a Premium or Ultimate for the laptop.

    But I may be over my head with all this as well. NOTHING is ever that easy for me! lol

    (wow, this turned out kinda long 'eh?)
  7. vnf4ultra

    vnf4ultra TechSpot Paladin Posts: 1,388

    Option 1 is kind of like a "fail safe" setting that should always work.
    Option 2 would be for RAID multiple drives, which you are no longer doing.
    Option 3 is what you would want, but may require a sata driver (press f6,etc) on installation of windows.

    Note, switching now likely won't work with the other options (cause bsod probably, or just not boot), as you basically have to set it right before you install your os.

    If you want to know more about AHCI, check the wiki.

    If you tried f6 drivers already and still got no hard disk detected in AHCI mode in xp setup, then you may have the wrong driver or a corrupted driver.
  8. Dominik

    Dominik TS Rookie Topic Starter

    Ditto iMoose! The easy fixes never seem to work for me either. It's always gotta be long, hard, and complicated. What is up with that, right dude, lol?

    Not that long, did you see my original post??? THAT was long!

    I'm thinking of just leaving it in IDE mode.
    What do you guys think, should I? Or should I keep trying to get it working in AHCI mode? Ummmmm, I'm confused...... What else is new though, :)!:stickout:

    What are the consequences of leaving it in IDE mode? Are there ANY? :confused: Holy schnikes!!!!

    I'm a patient guy, but I just slipstreamed my 8th DVD-R trying to get this thing straightened out. Not to mention the 15 variations of floppy disk drivers I tried. That's a lot of re-boots. It's ok, I'm a trooper, I'll get this straightened out sooner or later!
  9. Dominik

    Dominik TS Rookie Topic Starter


    Ok, after all I've been through, I've decided to just save myself the ongoing headache and to install my OS in IDE mode! Problem solved :)!

    There's simply too many things I rely on my computer for to have it not working.

    Thanks to all who gave feedback and support!!!!!

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...