I keep getting a IDE #0 error message coming up on my Toshiba a45-s121 laptop

By millieV7 ยท 6 replies
Sep 11, 2010
Post New Reply
  1. Hello everyone! Just the other day I tried to turn on my laptop and a message came up saying IDE #0 error and then says media test failure, check cable. What do I do? I'm not sure what to do because I have a lot of important stuff on my laptop that I need to get off. Please help!
  2. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    Let's try to get you into "Safe Mode" first. (I suspect it may not work, but let's try it anyway.)
    Turn your system off,
    wait a few seconds,
    then turn it back on and immediately hit the f8 key.
    If we are lucky this will get us to a black screen with the option to enter safe mode.
    Select safe mode, and see if it will boot to safe mode.

    If it will, then I want you to run ChkDsk.
    • Double-click My Computer, and then right-click the hard disk that you want to check.
    • Click Properties, and then click Tools.
    • Under Error-checking, click Check Now. A dialog box that shows the Check disk options is displayed,
    • Use one of the following procedures:
      • To run Chkdsk in read-only mode, click Start.
      • To repair errors without scanning the volume for bad sectors, select the Automatically fix file system errors check box, and then click Start.
      • To repair errors, locate bad sectors, and recover readable information, select the Scan for and attempt recovery of bad sectors check box, and then click Start.
    • Note If one or more of the files on the hard disk are open, you will receive the following message:
    • Click Yes to schedule the disk check, and then restart your computer to start the disk check.
    Let me know how much if any of this was possible for you to do.
  3. millieV7

    millieV7 TS Rookie Topic Starter

    Hey! I tried putting it in safe mode but nothing happens at all. The message PXE-E61 media test failure, check cable and PXE-M0F Exiting intel boot agent and then it says insert system disk in drive.
  4. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    Okay... two things... WITH THE SYSTEM OFF...
    1. Disconnect all usb peripherals at this point.
    2. Carefully remove the ribbon cable from the hard drive.
    3. Check for bent pins. (Very carefully straighten them if needed).
    4. Slide the ribbon cable back onto the drive.
    Sometimes a poor connection at the drive can cause this problem.
    A little oxidation may accumulate overtime.
    Just removing and reinstalling the cable may be enough to restore the connect.
    Let me know if this works, or if we need to do more.
    If you can boot now, then after windows has started, reconnect your usb peripherals.

    Caution, with usb peripherals, if you are powering them from the usb ports of your computer, you may be underpowered. It is always best to have your peripherals self-powered.
  5. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    Next I want you to go into your bios.
    When you power-on, press f2 immediately.
    Find the "boot" menu. This will allow you to enable and prioritize the following boot options.


    make sure HDD and CDROM are enabled.
    make sure that HDD is first.
    if there is an option to do so, disable LAN.

    The PXE error messages mean that your computer is trying to boot from LAN.
    But it also means that your system cannot find a local valid boot drive.
    Thus, my instructions for cleaning the contacts at the drive itself.
  6. millieV7

    millieV7 TS Rookie Topic Starter

    I tried taking the cable out and putting it back on to the drive but its still not recognizing it bc it keeps sayin insert system disc in drive. What's next if that didn't work?
  7. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    Did you try the bios settings (post #5)?

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...