New Laptop - Vista Internet only works in safe mode

By Desert Fox ยท 9 replies
Sep 4, 2008
  1. Ok so I had bought a new HP Pavilion dv5t-1004nr laptop with windows vista sp1 (64bit).

    I have Kaspersky AV 09 and I am pretty sure this is not a virus/malware issue because the computer is brand new and I had this problem when I first started using it.

    I'm experiencing no internet connection through wireless only, I am able to connect to ethernet or wirelessly through safe mode (with networking option).

    My computer says I am connected to the wireless host (full bars). There is no password needed to access it. Sometimes when I check the network and sharing center, my connection status looks somewhat like this:

    My PC-------host----x-----internet

    but for now it looks like this

    My PC------host----------internet

    I ran a test through windows and it says I am connected to the internet but using either IE7 or FF3 I do not get a page display.

    I personally checked my system for any malicious files (which there shouldn't be because I have AV on always and haven't downloaded any files yet)

    Please excuse if I have looked over something simple as I am a Vista newbie but help me figure out what is blocking my internet on normal mode.

    I'm open to suggestions.
  2. Richardw9

    Richardw9 TS Rookie Posts: 127

    Ive never used vista so bear with me.

    Is viewing web pages the only thing you cant do or are there other internet services that are unavailable?
  3. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 228

    Just because you have an antivirus program does not mean that you are not infected with some malware. While you are waiting for more suggestions from the group, try downloading SpyBot SD (it's free) and installing and running that. It will catch things that an AV package might miss. I also use SpySweeper, but that costs a subscription fee. Between my AV, SpyBot and SpySweeper, I tend to catch most problems, but even then something can sneak by if I am not careful.
  4. Desert Fox

    Desert Fox TS Rookie Topic Starter

    i wouldn't see how I've gotten infected so quickly when I only got the laptop yesterday. However, I have been experiencing this problem the same day I have received it (tested the wireless connection abilities).

    I am familiar with SB S&D and I still feel like this is NOT a malware issue. Just to be safe I'll rescan and wait on other suggestions, I appreciated the help.
  5. Richardw9

    Richardw9 TS Rookie Posts: 127

    eghh hem

    Is viewing web pages the only thing you cant do or are there other internet services that are unavailable?
  6. TearsInHvn

    TearsInHvn TS Enthusiast Posts: 57

    Try going into your Local Area Connection Properties and Uncheck Internet Protocal Version 6 (TCP/IPv6) as this looks for longer IP addresses. We are running out of IP addresses, so microsoft made version so it would look for the NEW IP's once we start using them. Only thing, is it searches for them now, thus blocking us from using the internet, after you uncheck this. Restart your machine and Happy Surfing!
  7. jass

    jass TS Rookie


    i'm having the same problem vith my Vista Ultimate 64bit. Tried to untick ipv6, did not help. When i restart, for some time i can browse web pages, but in a minute or two it's gone. Torrents still work though and msn messenger does not log me out, shows who has signed in, but wont let me have a conversation. I use nod32 antivirus, scanned, it showed no suspicious elements, so i too think that it has nothing to do with malware. Ping and tracert both work fine.
  8. TearsInHvn

    TearsInHvn TS Enthusiast Posts: 57

    I had the same issue. It took forever to display a webapge, A good 2-3 minutes. This was do to my add-ons. I disabled them. And now I can surf with no problem. Only thing is when playing games I have to Firefox because now my java doesn't work.
  9. jass

    jass TS Rookie

    Which add-ons, for what application? Did you uninstall Java runtime enviroment? Now internetnet works when ever it wants to.
  10. GrifterViper

    GrifterViper TS Rookie Posts: 18

    Hey, I had this same issue with the local only with Vista Business (SP1). I made a registry change, though it didn't seem to help. When I tried to do the old ipconfig /release then ipconfig /renew in the command prompt, I got the "elevation" required message. Ran across an article that said that you just click run, type in command, right-click the command prompt button, and then run as administrator. Once you get into that prompt, you can do the ipconfig release/renew bit and it seemed to clear things up for me.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...