Problems installing steam via wine

By BiZ ยท 6 replies
Nov 22, 2005
  1. Ok so i ran the install and it was crashing at 27%, i found out it was because of permissions and ran it as root and it worked fine. Now when i try to open steam.exe it gives me an error:

    Steam.exe (main exception): Win32 StructuredException at 1017c135 : Attempt to write to virtual address 4 without appropriate access rights.
  2. BiZ

    BiZ Topic Starter

    Its obviously a permission problem but i dont know where it is trying to write to so i cant set the permissions right. Anyone know where its trying to write to? I've tried setting all permissions in the fake windows directory to read/write/execute for all and setting mozilla firefox activex controller to read/write/execute for all and all the files in the steam directory. Still wont work.

    Any help would be much appreciated.
  3. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    It looks like a problem writing to a memory location, not to a file. Possibly a bug in Wine or the limitation of Linux. Try running Wine as root maybe?

    Is Steam supposed to be runnable with Wine? Check the WIne homepage (or the page of your Wine-based package) for a list of compatible apps and possible hints to running them.
  4. smtkr

    smtkr TS Rookie Posts: 131

    I'm not sure, but I think you're going to need Cedega for Steam.
  5. BiZ

    BiZ Topic Starter

    It's WineCVS which is cedega.
  6. BiZ

    BiZ Topic Starter

    Ok so i deleted my profile and went to make a new one and its getting a error. Here the error log.
  7. Tuntis

    Tuntis TS Rookie Posts: 21

    cvscedega is unstable; If you want to play games in Linux, you should consider getting the real Cedega.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...