Program Uninstall/Install Problem

By olefarte
Dec 27, 2003
  1. I've got two problems. I have a program named "Fast Defrag". I uninstalled it from "Add/Remove", it doesn't show up now. But, it's still in "Start/Programs", and the icon is still on the desktop. I've tried to uninstall it from Programs menu, and I get "Cannot uninstall, does not exist". But, it IS still there and it still works. How can I get rid of it.

    Epson printer, it's been installed for about six months. Now it won't work. Evidently some files somehow got corrupted, I'm not sure? I try to install the drivers, they apparently install, but they don't. I try to uninstall all things Epson, get "does not exist". At this point I can't use my printer.

    Anybody got any ideas what I can do?
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    As for the fast defrag thing, the uninstaller may have been poorly written and it "forgot" to remove the Start Menu and Desktop items. If the thing itself is gone from Program Files then you can just delete the links from Start Menu and desktop.

    Are you uninstalling the Epson drivers via Add/Remove Programs? Delete the printer in your printers setup. Install the MS drivers for the thing, then install Epson drivers again.
  3. khosw

    khosw TS Rookie Posts: 36

    see if the website of Fast Defrag has a manual uninstall method, else you can reinstall it to the same drive and folder and uninstall it using the uninstaller in the program's folder.

    disconnect the printer from the computer, open the printers folder in control panel, select the epson printer and delete it. turn on the printer and make sure you have a bidirectional ieee printer cable hooked up to the computer. open printer folder and add printer use autodetect.

    hope this helps.
  4. olefarte

    olefarte TechSpot Ambassador Topic Starter Posts: 1,345   +13

    Ok, first, khosw, I did what you said on the Fast Defrag, downloaded it again. After reiinstalling, it finally uninstalled this time, don't know why I didn't think of doing that, thanks.

    On the printer, when I tried to install the drivers, all the other junk that comes with them, installed fine. The drivers appeared to install, but they were not in the Epson folder. I tried to "add Printer", and it said that "could not complete operation", and my computer did not detect the printer at all. I triey to uninstall first from the Program Files, and then from Add/Remove, (it was still there), in both cases, Windows said the file was not there.

    Anyway, this problem is solved. I did a repair install of Windows XP, and it detected the printer afterwards, and I was able to install the drivers.

    I guess things are back to normal now. Thanks for the replies guys, I appreciate it.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...