1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Still trying in vain to update my BIOS

By Lethal Larry
Sep 5, 2010
Post New Reply
  1. HI guys,

    I desperately need some expert help, here.
    I have an ASUS M2N-E motherboard, here's the site for it:
    h t t p ://ca.asus.com/product.aspx?P_ID=NFlvt10av3F7ayQ9
    (had to add spaces to the first bit, as the system here won't let me post links for some reason...)

    I've had it for about 5 or 6 years, with a 2.2 Ghz single core processor. It's been good enough up until I bought Starcraft 2 - and I failed to notice that the game requires a 2.6Ghz single core processor as a minimum, preferably a dual core.

    I figured I was probably due for an update, and decided to get a new computer. Then I discovered that all the computers within my budget would fail to get the job done. THEN I noticed the box that my motherboard came in... and for the first time noticed it said in big letters right on the front of the box: "Dual-Core CPU ready". Well, duh.... if I'd been observant enough to notice that years ago I would have updated my bloody processor ages ago.... but, oh, well, I figured, hey! I'm saved!

    So, I went out and bought an Athlon II X4 635 2.9Ghz quad core processor - much to my amazement, it's on the list of supported CPUs for my motherboard. The M2N-E is an AM2+ chipset (I think), and the new chip is AM3 - but the ASUS site still insists it's kosher.

    So here's the problem:
    it says I have to update my BIOS - it's a little scary, I admit, since one of my computers in the past died during the procedure - but anyway, I went for it. Repeatedly. I tried the 5001 BIOS, but whenever it got into the ASUS EZ Flash 2 utility, it ALWAYS hangs up when it says "erasing blocks" - the status bar next to it never moves. I left it for a half an hour and it still didn't move.

    I then tried the 3001 BIOS - same thing.
    I used a USB flash drive to store the new bios version on, as the motherboard's manual says to... it also specifies something about using a FAT 32/16/12 format - presuming meaning that the file allocation tables need one of those three formats... however, when I format my USB drive, my options are FAT, FAT 32, and FAT32 ex, I think. It was set on FAT, originally.

    Using that format, the EZ BIOS Flash utility does see the USB drive and seems to be able to read from it - it can see the file name and date of the BIOS version I'm attempting to install.

    So after that failed, I tried reformatting it to FAT 32, but then the utility wasn't able to see the USB drive at all. I reformatted it back to FAT again, and again it could see it, but it still hangs up after "erasing blocks".

    So, yeah, I'm kinda stumped.

    Oh, the manual also says something about a second way to go about it, using the AwardBIOS flash utility, which I've downloaded - but it requires a boot disk, and I don't have a floppy drive.
    Is it possible to use a USB drive to make a boot disk?

    After you tech wizards manage to get my head put on straight about this, I'll have to beg for help about my new graphics card, too - I bought a XFX Radeon 5770, but whenever I put it in, the system doesn't even boot up.

    I think I'm just gonna go buy an abacus.

    *edit* oops....
    Windows XP home edition
    4 Gb DDR2 ram
    500 w power supply
    uhh... I dunno if there's any other relevant info here....
  2. raybay

    raybay TS Evangelist Posts: 6,908   +10

    Floppy drives with cables are less than $4.00 around these parts... maybe that is the best way to go for a six year old motherboard.

    Hard to believe that board is Dual Core Ready? or that it is 5 or 6 years old. Tell us more?

    you want to be very careful flashing a BIOS if you have never done it before... That is a certain way to ruin a motherboard, unless you have a good manual or guidance... for first timers.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...