1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

U3 Drive Help

By TrayDogg35
Jul 7, 2009
  1. I have a U3 Cruzer Micro. The problem I am having is that I have been saving things on it fine for months with no problem. I am on a network at my job with 4 pc's on the network and one offline. I have no problem with the U3 Drive when I save something onto it from the out of network pc but when I go to any of the network pc's it says that "The device cannot start - Code 10" I have tried a driver update and powering down and back up. I have even tried ejecting all drives safely and then putting it back in but nithing is working... help
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Try this:
    "Start->Run->cmd /k reg delete,
    hkcu\software\microsoft\windows\currentversion\policies\explorer /v NoDrives /F
    May require a reboot afterwards -
    just ensure that command comes back "successful".
    the highest decimal value that should ever exist there would be 67108863 (or hex, 3ffffff), which effectively 'hides' every drive from A to Z"...
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    If i might add some info....
    Tmagic650: that registry tweak affects Windows group policy that allows you to hide or not hide specific device partitions. You may be thinking of a different policy that allows or denies users to mount new devices (vs. just hiding them)

    In any case, doesn't hurt to try it

    /* EDIT */
    A couple thoughts of other things to try
    1) Remove the U3 Launchpad functionality from one of the U3 drives and re-test it. (NOTE: Check if this may delete all current info on flash. i don't remember). but interesting to see if problem persists if normal USB flash (vs. a U3 USB flash)
    2) You might also (after step 1 above) try removing the upper/lower disk filters on just one network computer and test the flash on that one computer to see if it makes any difference See for instructions on how to remove your upper and lower class disk drive filters
    3)We might also want to check/change policy regarding mounting USB devices... but can you mount any other type of removalbe USB drive??? or is your problem specific to the U3 flash drives?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...