Windows XP and VIA VT8237 SATA BSOD

By harrykh
Jan 23, 2007
  1. Hi, I have a few 100g HDs hooked up already and there's really no room left for new HDs. So I thought I'd use SATA now.

    Before I don't use SATA, so I turned off the controller in BIOS. Less loading I thought. I also turned off the serial ports, etc. Stuff I don't use.

    Now that I have bought a 160g Seagate SATA I tried turning back on the controller in BIOS. But everytime I boot to WindowsXP now I get the BSOD. Telling me to remove any new installed HDs and Controllers and to check for viruses. I haven't installed the HD yet just enabled SATA in BIOS. I thought XP should install the drivers for the RAID Controller first before I hooked up the HD.

    I dual boot with Win2K and it loaded just fine. It's XP that's giving me problems. Right now I turned off the controller in BIOS and it booted fine.

    Can anyone help me ?

    My Mobo is a KT6 Delta VIA KT600 and installed the latest VIA drivers. XP is patched with the latest (auto update).

    Thanks. I'll provide more information if needed.

    I should add that not so long ago I had to reset the BIOS and everything was at the factory default. XP booted just fine, after installing the RAID controller, Serial Ports, etc. Stuff that I disabled before in BIOS.

    Now it doesn't work anymore. Is it the new VIA drivers ?
  2. harrykh

    harrykh TS Rookie Topic Starter

    No ideas ?
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    There's a couple of things that come to mind.

    First, if you have an Intel computer, disable "AHCI mode" (aka 'enhanced SATA' or something simliar or enable IDE emulation) in the BIOS. If you have a SATA II/300 controller, force it to run as SATA I/150 instead if you can. Also disable any RAID features while you are in there - You want to use plain ol' vanilla SATA while troubleshooting.

    But, it sounds like to me that you might have an old-fashioning IRQ conflict on your hands. Windows' ACPI implementation generally does a reasonable good job of sharing IRQs, but sometimes it needs a little coaxing. For troubleshooting, I would remove all of your unnecessary PCI cards (Sound card, TV tuner, modem, network card etc...) from the PC and try to boot up into Windows again. If it works, then there's a chance IRQ problems are to blame. This is a sign of configuration or driver problems. Uninstalling the drivers for your SATA, updating them or downgrading them may fix the problem. Alternatively, running your computer the "Standard PC" HAL may also resolve your issue... providing any of this is due to IRQ conflicts.
  4. harrykh

    harrykh TS Rookie Topic Starter

    My computer is AMD and the BIOS option for RAID in this MOBO is limited to "Enable SATA" with the suboption "Enable 2x". I tried every combination, no go.

    I removed my TV turner, Ethernet Card and still the problem shows up.

    How do you remove the SATA drivers that I once installed ? I don't see anything in Device Manager. I'm not expecting it to be there since I have to disable it if I want get into windowsxp.

    I had a HD crash recently and really needed that new HD to recover things to. As I've said Win2k SP4 works with SATA, flawlessly, and I'm almost done recovering. But I don't really want to use it as my primary OS.

    I'm regretting getting SATA now as I could just buy a PATA HD and use a HD enclosure and have my storage as a portable USB drive. Whats more I've heard that SATA doesn't really offer any benefit unless it's a "Raptor" ? I haven't googled that yet but I know that mine is not one.

    However if you have any more ideas please. I can't take this drive back now :p

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...