Referenced Memory Error

By Biznich · 271 replies
Nov 15, 2003
  1. helix1

    helix1 TS Rookie

    Just an addendum to my last post,

    I enabled drwatson as my default debugger by doing a 'drwtsn32 -i' from the Run command.

    I wonder why HP tech, in the three times I spoke to them about this issue, never asked me about drwatson ??? Well, 'nuff said on that I guess.

    Anyway, hopefully when it happens the next time there'll be an error log. If in the meantime anyone has any suggestions based on what I wrote, I welcome them.

    I'm curious, would bad memory slots be a possibility? I asked that question to two of the tech reps, and they both said that if I had bad slots, I would get a beep when I tried to turn boot up the computer, and nothing would happen.

    A third one said it might be a possibility that I would still be able to boot up with a bad slot.

    Anyway, just asking, since these geniuses at HP didn't even ask about DrWatson.
  2. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    When hardware occurs at kernel mode, system crashes with blue screen. When hardware occurs at user mode, application occurs and writes an application log to Dr Watson (provide it is enabled). Usually Dr Watson is the default debugger unless you have another debugger such as Viscal C++ or it is disabled. Repost if you have something is locked at the Dr Watson log. BTW do you find any minidumps at the folder \windows\minidump?
  3. helix1

    helix1 TS Rookie


    No, did a search on my c drive. No folder called minidump anywhere. As I said in my previous email, I enabled watson with the ''drwtsn32 -i' from the run menu.

    It said "Watson has been installed as the default debugger" That means it should run automatically next time any sort of crash happens, right? If not, then please let me know. I want to make sure it's enabled to run automatically.

    I guess it didn't come enabled.

    Since I don't get blue screens, that means errors are not at kernel mode. Is there any chance that bad ram slots could be the problem? Or are you saying that bad ram slots would trigger blue screen crashes?

    Thanks for your continued time.
  4. helix1

    helix1 TS Rookie


    I've attached a copy of the dr watson log following a crash of my ATI Multimedia Center drivers. I've also had this happen before, though it usually came with a memory refernce error. This time it didn't, maybe because I had Dr Watson on.

    Anyway, the log does show affected memory registers. I haven't yet had another ccapp error since I enabled the debugger yesterday.

    Unfortunately, this isn't something I can cause to happen at will. It just happens when it feels like it. Next time it happens, it'll at least leave a log.

    I think the two are related, though I've had crashes even before I installed the ATI drivers, so ATI isn't the cause. All of the crashes happen when I close the applications.

    BTW, I don't know what you want included in the log file. When I enabled Dr Watson, I set it to give a full log type, including dumping symbol table and thread contexts.

    If this is too much info, please let me know and I'll leave out the parts you don't want the next time.

    I'm sorry to continue imposing on you, but this board is my last resort. I'm out of ideas as to why I'm getting problems with a 3 week old machine.

    One important item, from your earlier postings on this message thread, am I correct in assuming that if the cause of my problems were HW related (ie. bad cpu, bad memory slots, or bad memory chip), that I would be getting blue screen errors?

    Is this right?

    I'm anxiously awaiting your feedback. Thanks
  5. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    I've analyzed Doctor Watson dump and it only have one entry. The failing instruction is not logical as I do not hard code the absolute address within a program. I suspect this memory corruption. Maybe it is one or two bits memory corruption at memory location 0005001200f6.

    0005001200f6 add [f6001200],al ie add register al to location f6001200

    I think it is cache memory error of CPU or motherboard. If the cache memory error occurs at kernel mode, windows crashes with blue screen. Vice versa if the cache memory occurs at usermode, it causes application error with "Access Violation" or "Illegal Instruction". Usually windows usually run at user mode and if the application program request system service and it switches to kernel mode. General spkealing 80% of CPU is at user mode and 20% at kernel mode.

    If you can provide more Dr Watson log and minidump, I can provide more evidence to support that it is hardware problem.

    Application exception occurred:
    App: C:\Program Files\ATI Multimedia\main\ATIMMC.exe (pid=1284)
    When: 5/3/2005 @ 21:58:32.217
    Exception number: c0000005 (access violation)

    eax=008a0100 ebx=00000000 ecx=0f32fe80 edx=0f6faa28 esi=00babef8 edi=00ba2eb8
    eip=0f670acf esp=0f32fe38 ebp=008ab600 iopl=0 nv up ei pl zr na po nc
    cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00000246

    function: <nosymbols>
    0f670abc 0000 add [eax],al
    0f670abe 0000 add [eax],al
    0f670ac0 0000 add [eax],al
    0f670ac2 0000 add [eax],al
    0f670ac4 b000 mov al,0x0
    0f670ac6 0000 add [eax],al
    0f670ac8 90 nop
    0f670ac9 0000 add [eax],al
    0f670acb 0000 add [eax],al
    0f670acd 0018 add [eax],bl
    FAULT ->0f670acf 0005001200f6 add [f6001200],al ds:0023:f6001200=??
    0f670ad5 0108 add [eax],ecx
    0f670ad7 0228 add ch,[eax]
    0f670ad9 6a6b push 0x6b
    0f670adb 0f7400 pcmpeqb mm0,qword ptr [eax]
    0f670ade 7500 jnz 0f670ae0
    0f670ae0 61 popad
    0f670ae1 006c0065 add [eax+eax+0x65],ch
    0f670ae5 007800 add [eax],bh
    0f670ae8 6300 arpl [eax],eax
    0f670aea 6c insb
  6. helix1

    helix1 TS Rookie

    Hi cpc,

    Thank you for getting back with me. I am attaching another Dr Watson error log of another ATI crash that happened yesterday.

    Unfortunately, I come up blank with the minidump. I don't understand why that isn't being produced. I've checked under Sysytem in the 'Advanced' tab for debugging, and it shows a minidump is supposed to be generated for system failure.

    Maybe the errors I've been getting don't constitute system failure.

    Anyway, so you're saying it's a possibility of failure at a HW level, even though I'm not getting any blue screen errors, or errors at kernel mode?

    You know, one thing unique about the Athlon processor that isn't present in the Intel pentium architecture, (you probably know this already), is that the athlon 754 pin 64 cpus have single channel memory controllers on the cpu.

    I'm just wondering if that could be another area where the HW failure lies, aside from the cache.

    Also, do you think it might be due to a defective memory chip, or the ram slots?

    Forgive me for stupid questions, as I'm not at all familiar with these type of errors. You're the most knowledgeable person I've run into so far.

    Anyway, tell me what you think of the latest dump from Dr Watson.

    I haven't yet gotten a recurrence of the ccapp failure since I enabled Dr watson, but it usually comes and goes. But when it does, I will send it to you

    Again, thank you VERY MUCH for helping me cpc. I really appreciate it. :) :)
  7. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    The new DrWatson log does not have evidence that it is a hardware issue. Repost if you have a new DrWatson log.

  8. helix1

    helix1 TS Rookie

    Thanks for getting back with me cpc, I will post new errors

    Hmm, so you say the latest log doesn't indicate a HW issue. I'm confused, the error deals with the same app. Why one log that indicates a HW issue, and another not?
  9. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    The failing instruction of the last Watson' s log is a valid instruction. Unless I have the source code, it is very hard to determine the root cause of an access violation program. It may be hardware or software. I will never commit anything that I am not sure. Don't expect I can draw a conclusion from a dump. For some case the evidence is very obvious I can have a conclusion. For example the previous log, although the failing instruction is valid and it is unlikely that it refers the absolute address as the author very sure that the address never change. It is the reason I assume it is hardware error. If the new Dr Watson log gets nt status code is 0x'1d' (ie illegal instruction), it is the hardware problem. It is very hard to determine whether it is a hardware or software error from the log and dumps.
  10. helix1

    helix1 TS Rookie


    I know, that's the problem with Windows machines.

    Anyway, I appreciate your feedback nonetheless, and when I get new memory refernce errors, I will post them for diagnosis. You seem to be the most technically knowledgeable of everyone I've consulted thus far.
  11. helix1

    helix1 TS Rookie


    Attached is a log of more errors. If you could provide me with your input as to any possible indications of HW, I'd appreciate it. Thank you.

    Attached Files:

  12. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    Your Dr Watson log have only three entries. I don't find any known error for ATIMMC.exe with execption code c0000096 at google. Usually execption code c0000096 is a coding error. I believe that it may be one bit memory corruption and change the instruction for non-priviledge instruction to priviledge instructon. If it is a hardware error, a lot of failing at different modules such as ATIMMC.exe, lnkstash.exe, ccApp.exe and Juno.exe

    Application exception occurred:
    App: C:\Program Files\ATI Multimedia\main\ATIMMC.exe (pid=4088)
    When: 5/8/2005 @ 16:55:07.812
    Exception number: c0000096 (privileged instruction)
    Application exception occurred:
    App: C:\Program Files\ATI Multimedia\main\ATIMMC.exe (pid=3556)
    When: 5/7/2005 @ 14:31:40.406
    Exception number: c0000005 (access violation)
    Application exception occurred:
    App: C:\Program Files\LinkStash\lnkstash.exe (pid=3996)
    When: 5/7/2005 @ 20:44:32.890
    Exception number: c0000005 (access violation)

    The information that you provide is very limited and I don't have sufficient evidence to prove it is a hardware problem

    1) Apply the latest patchto ATIMMC.exe
    2) The memory corruption may be caused by faulty CPU or M/B. Do you any minidump at the folder \windows\minidump. If yes, attach 3 to 4 minidump here.

    1) Search google and I have no idea what is lnkstash.exe?
  13. helix1

    helix1 TS Rookie


    I'll see about d/l'g the latest copy of the drivers for my videocard, if they have any, maybe that will help.

    Linkstsh is a bookmark app I run from the systray.

    Btw, the references you made to ccapp and juno were from my previous postings of the memory reference errors, right, and not from the log I sent you? Because I couldn't find any reference to them in the log.

    You know what's ironic, I haven't received the memory reference error for ccapp ever since I enabled the log (??), which is unusual. I've been eagerly waiting for some specific memory reference error dialog boxes to show up, but no, even though I have had some apps lock up on me. I'm puzzled about that.

    The other thing about the errors is that they'll show up after my system has been running for a while.

    As for a minidump in the Windows directory, I haven't been able to find any, which is also unusual (??) I check everytime an error happens.

    Maybe I don't have it enabled. I was under the impression I did. Matter of fact, I've attached a screen capture of the 'Startup and Recovery' part of System Properties that shows minidump is enabled, so I don't understand.

    Is there someplace else I need to enable this, cpc? What I did do however, two weeks ago, was to change 'Error Reporting' in System Properties to "just notify me when a critical error occurs".

    I don't know whether that has an impact on producing a minidump.

    Again, thank you for continuing to provide me with input.

    Attached Files:

  14. Bailywolf

    Bailywolf TS Rookie

    I have a simple solution for some of these issues.

    I had a ticket on one of these among the machines I support, and I was concerned it was a programming issue with some of the specialized proprietary software we run here (a University fundraising and development office) for scanning and associating imaged documents with records in our alumni database. But I found this forum, and it got me looking into a possible video issue, because this error only popped up when the display application for these images fired. I checked the video driver versions, and found the video driver was one signed by NVIDIA but NOT by Microsoft. I checked, and a recent set of Windows Updates had been installed around the time this error started showing up. So, I found a current Microsoft signed driver for the video card, and this totally licked the problem.

    If this error seems to be associated with video rendering, it may be as simple as finding the most current driver for your card.

    Hope this helps.

  15. helix1

    helix1 TS Rookie

    Thanks for your suggestion Bailywolf.

    First of all, let me make sure I understand, you had an a810n HP athlon 64 3300+ machine? And did it show memory reference errors or did it show other application errors with the video drivers?

    As far as my machine is concerned, I got errors running with the video drivers that came with this machine for their Intel onboard lousy video, and with my ATI card. So, either way.

    It's interesting to note how my errors seem to migrate, first with my Juno dialer, then with ccapp, and now with ATIMMC.

    I no longer use the Juno dialer, but as I said above, I haven't had any errors with the ccapp in over a week, and now those errors have been replaced with errors in the ATIMMC.

    At any rate, I have upgraded the drivers for this, so I'm waiting to see if that makes any difference.

    I hate these ambiguous problems. I just wish it was a straightforward diagnosable HW issue.
  16. SPK

    SPK TS Rookie

    Referenced Memory Error--Matrox driver

    I had a reference error message on closing several applications. I read a post by DEC who had a Parahelia board and noted the problem to resolve by closing the matrox powerdesk services. I have a millenium 650 PCIe card, disabled the service, and everything worked fine. I then downloaded the latest version of matrox powerdesk, which has fixed the problem. I suspect that other individuals may be having these errors because of bad code in background services. I have .net framework installed and working fine, so dont think this was related. Thanks to all on this forum.

  17. MJL54

    MJL54 TS Rookie

    More of the Same?

    Hi, I've been perusing some of the posts here re this memory referencing error, and it sure is a long thread; started back in 04, I believe?

    It seems that this problem is quite universal, which in some ways makes me feel better because at one point I thought it was me doing something I shouldn't have. Of course, I realized soon enough that I was just falling in with the general profile of a Microsoft victim, blaming myself for the bugs that are inherent in the system. I believe Bill Gates stated Microsoft's arrogant, condescedning and patronizing attitude best when he declared that Windows had no bugs; if anything, it had to be the fault of the user!

    Ok, so here I had a similar occurrence with the memory referencing thing. Mine reads: "Application Error:
    The instruction at 0x77f536f9 referenced memory at 0x00a14bbc. The memory could not be 'written.' Click OK to terminate the program." This was after I x'd out of Outlook Express.

    Seems to me that any number of conditions can exist on XP for this to happen - and nobody knows what causes it, and there seem to be all kinds of "solutions." It's obviously one of those silly little things that Bill Gates didn't want to worry his billionaire head about because it would delay the release of his latest edition. Exactly what happened in my case was that I'd just come off using Finale, which is a music notation program. After cleaning out my Temp files, which Finale accumulates in great number, I went to Outlook Express (Oh, now there's always a surprise with Outlook Express). I have it set up so Outlook Express downloads my mail from a broadband server. Well, here were all of my e-mail headers, but no text in the content at all. Just big blank pages and no explanation! So when I closed out Outlook Express, that's when I got that memory referencing error. The funny thing is when I went to my high speed server page, there was no e-mail! Where did they go? Well, who knows! But what I did was open up Outlook, the plain Outlook that's on the desktop, and set it up to import my Express files, and it was fine. Now I don't care if I get a referencing error because I'm not using Outlook Express. It's just a workaround, but as to the cause, well I'm just as ignorant as anyone else. I wish we could contact some high-end programmers who may have had some experience with this and get to the bottom of it. Windows has a lot of these mysterious ways and there seems to be no explanation for any of it.

    I'm looking forward to trying Linux, but I hear it's not easy.
  18. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    DrWatson log has the most useful diagnostic information of your problem. Attach the following files at any webspace. I will study your log and dumps.
    C:\Documents and Settings\All Users\Application Data\Microsoft\Dr Watson\drwtsn32.log
    C:\Documents and Settings\All Users\Application Data\Microsoft\Dr Watson\user.dmp

  19. TheGreatAnt

    TheGreatAnt TS Rookie

    Similar Problem, been through thread

    My error is:
    "The instruction at 0x241f94f7 referenced memory at 0x00ff0cc0. The memory could not be "read"

    Click on OK to terminate the program"

    The specific memory instruction changes from error to error.

    I have not gotten a BSOD. Error occurs when playing games (specifically HL2 and Guild Wars). Usually I'll have been playing for about 10 minutes, but it can be up to an hour. I have not tried playing movies of any sort on this computer yet, so I don't know if that would also generate the error.

    The machine was put together by myself with all new parts (except the floppy drive). It was built within the past 2 weeks. OS is XP w/ SP2. I wanted to stick with SP1, unfortunately it won't retail anywhere that I found. It turns out I can't roll back from where I'm standing right now.

    The machine has few programs installed on it. No anti-virus or anti-spyware is present. Only things running that are not directly associated with windows would be the nVidia desktop manager and the creative volume controller. Also, the two things that currently launch at startup are Trillian and Steam.

    No Dr. Watson folder exists, I don't think I have the app. If I do, it hasn't done anything yet. Neither is there any folder named minidump on my computer.

    Computer specs (also in profile):
    Important stuff
    AMD 64 3800+ Newcastle
    2x1gb Corsair XMS 3200PRO (passed an extensive memory test last night)
    DFI Lanparty SLI-DR
    eVGA GeForce6800Ultra 256 PCIx
    Creative Audigy 2 ZS Platinum Pro

    Less-Important stuff
    560w PS
    2 SATA hd, 1 74gb Raptor, 1 250gb
    DVD burner
    DVD reader

    OK, so instead of leaving that there, I'm with the captain on trying to find the root cause. Currently, I've noticed a few things.

    OSs that experience this problem seem to be XP, XP SP2, 2000, and 2003. XP SP1 does not seem to experience this problem as much (at least not with the games) and that matches my personal experience. I personally have gotten the problem with both XP and XP SP2. When I've had SP1, I have not experienced this. If you DO have a different OS from those listed and are experiencing this, please let us know.

    CPU has been both AMD and Intel, though mostly AMD

    Memory has been everything from a lot to a little, by multiple companies.

    GPU, same thing, everything from onboard to high powered.

    Causes have been everything from closing IE to starting the computer to being in the middle of a game.

    SOLUTIONS have ranged from deleting random software to changing settings in IE to buying new hardware.

    So (and I know this is obvious) the error message clearly has no single solution. It is not software exclusively, nor is it hardware exclusively. Unfortunately, it is the interaction between the two, which is definitely the most obnoxious type of problem, as neither company can really be contacted with any hope of getting the necessary supported. The only similarity we have to work with is Windows here. That's not a bash against windows however, it is merely the realization that this error message is a generic response for a memory problem that can be caused by any number of things. One thing that does seem to be a theme with this message is it's relation to somehow utilizing the graphics card, either for playing a movie or for gaming. That is not true in every case, though. IE has been related in many cases as well.

    Essentially, I need to figure out how I can get error logs of what is going on, and then find someone who can interpret them and let me know what is wrong with my specific system. cpc2004, you look like the potential person to help me - if you are up for it - but if anyone knows of a website that has any additional info on this at all, please let me know.

    And if anyone needs any info from me about my computer, feel free to ask.
  20. MJL54

    MJL54 TS Rookie

    Dr Watson comes with every Windows Setup. You can find it in C:\Documents & Settings\All Users\Application Data\Microsoft\Dr Watson

    Just do a search and it'll take you there.

  21. Bobcat1132

    Bobcat1132 TS Rookie Posts: 79

    my suggestion replace each piece of hardware until you figure it out because it could be any thing maybe even try the hdd and make sure everything is connected correctly
  22. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    Your problem may be related to virus, software problem or faulty ram. The DrWatson log has the most useful diagnostic information of your problem. Maybe you disable DrWatson. Refer the following URL to activate DrWatson;en-us;308538
  23. TheGreatAnt

    TheGreatAnt TS Rookie

    Not a virus, the situation occurred twice on two different OSs on this comp (windows XP and XP SP2), one of which had not been attached to the internet. Problem is possibly a pure software problem, but that's very unlikely. Faulty RAM is not the cause, as far as all the extensive memory checkers I've run can tell.

    I would guess that this is just a compatibility issue between certain applications and hardware. Though some of it seems to be tied very directly to IE, none of the fixes involving that work, and I do not seem to crash when using IE. I generally use Firefox, but of course IE is pretty much throughout the windowXP operating system.

    I did a heck of a lot of research on this. For those of you with crashes that seem to relate to video cards, media playing, and/or gaming, here is a potentially helpful website.

    While the fixes listed on that website do not necessarily work, I DID manage to extend the overall life of any game I am running from approx. 15 minutes to about 45 minutes. Still not good for all types of gaming, but certainly more functional for campaign modes.

    Microsoft also released a patch for this exact problem in both WindowsNT and Windows2000. Apparently they didn't fix the overall problem, so we will have to wait for the patch to come out for XP and use temporary solutions and workarounds until then. Also, if gaming is where you are experiencing issues, game companies are also working on patches to stop this from happening.

    For the extreme of us out there, the problem for NT and 2000 was:

    "This problem is caused by a file extension that contains more than 260 characters to the right of the period. The buffer overfills and causes the error message to occur."

    Quoted from

    If you research it for NT exclusively, you will find the same thing. Not sure if it is that exact same problem for all the XP cases that have been cropping up, but it could certainly explain a few of them that I have seen on this thread.

    More research into the gaming aspect will bring you this:

    "The #1 cause of this problem is the memory on your motherboard.

    If you have a modern motherboard and you have more than one memory module installed, and the modules are different speed ratings or diferent sizes there is a very good chance this is causing your problem.

    Especially on Nforce2 and Nforce3 motherboards (AMD processors) this has been historically the most reported error, with VIA motherboard chipsets next followed by a very small number of Intel motherboards."

    Apparently the memory sticks become desynced with the CPU through the mobo, as someone was saying earlier. Good call, whoever that was.

    Removing all but one stick of memory and seeing if you still get the problem can let you know if that is causing it.

    Note that none of the components are faulty when this is the case, they simply refuse to work together properly.

    If anyone else finds anything more, please post it here, I will continue to moniter this thread closely.
  24. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Some faulty ram can pass memtest as memtest is not a reliable tool to test the memory
  25. Bobcat1132

    Bobcat1132 TS Rookie Posts: 79

    use mozilla not ie?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...